Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox will not open on my laptop

  • 3 uphendule
  • 1 inale nkinga
  • 9 views
  • Igcine ukuphendulwa ngu James

more options

Firefox will not open on my laptop. The tab opens but the homepage does not appear even after waiting 5 minutes. I've run all my updates to my Dell Laptop. I am fortunate to have it on my phone. I am a perpetual monthly subscrber.

Firefox will not open on my laptop. The tab opens but the homepage does not appear even after waiting 5 minutes. I've run all my updates to my Dell Laptop. I am fortunate to have it on my phone. I am a perpetual monthly subscrber.

All Replies (3)

more options

jscher2000 said

Could this be relevant? A couple of other users identified Webroot (security software) as blocking 64-bit Firefox 97 -- released today -- from running properly: If you are still running an earlier release of Firefox, this would not be your issue.

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

If you have Windows 10 or 11, and Webroot security software, and 64-bit Firefox 97, there is an incompatibility which cripples Firefox.

People are working with Webroot to issue an update.

Until then, a user posted that one workaround is to run Firefox 97 in backwards compatibility mode. I haven't tested this myself, but here is how you would set that up:

(1) Open the Properties dialog for your Firefox shortcut. Either:

  • right-click a Desktop shortcut, then click Properties
  • right-click a pinned Taskbar icon, then right-click the Firefox (or Mozilla Firefox) item, then click Properties

(2) Switch to the Compatibility tab

(3) Check the box for "Run this program in compatibility mode for"

(4) If the selector for that option is not set on Windows 8, switch it to Windows 8

As a result of this change, you may notice that some Windows 10-specific features and styling are disabled. However, I am not aware of any major changes. If you experiment with this, let us know your experience.

more options

In case you do have Webroot.

https://www.mozilla.org/firefox/97.0.1/releasenotes/

Fixed Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations