Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox giving 504 Gateway Time-out error on site that Chrome loads just fine

  • 3 uphendule
  • 2 zinale nkinga
  • 499 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I'm running 96.0.3 (64-bit) on Windows 7 Ultimate 64-bit. Firefox has suddenly started having trouble with my local library's website. Chrome loads it just fine. Here's a sample URL:

https://jocolibrary.bibliocommons.com/v2/record/S36C592151

Firefox tries to load that for 60 seconds or so and then says "504 Gateway Time-out The server didn't respond in time. "

When I go to the main site:

https://jocolibrary.bibliocommons.com

Firefox will load it, though it takes a while, and everything seems ok except it flashes the message "Could not retrieve availabilities via API. Baker_And_Taylor short-circuited and fallback disabled." When I try to use the Search function on the page, I get the 504 error mentioned above.

I've tried running Firefox without add-ons and the same thing happens. I've tried deleting the cookies for this site as well.

Firefox has never had trouble with this site before late last night.

I'm running 96.0.3 (64-bit) on Windows 7 Ultimate 64-bit. Firefox has suddenly started having trouble with my local library's website. Chrome loads it just fine. Here's a sample URL: https://jocolibrary.bibliocommons.com/v2/record/S36C592151 Firefox tries to load that for 60 seconds or so and then says "504 Gateway Time-out The server didn't respond in time. " When I go to the main site: https://jocolibrary.bibliocommons.com Firefox will load it, though it takes a while, and everything seems ok except it flashes the message "Could not retrieve availabilities via API. Baker_And_Taylor short-circuited and fallback disabled." When I try to use the Search function on the page, I get the 504 error mentioned above. I've tried running Firefox without add-ons and the same thing happens. I've tried deleting the cookies for this site as well. Firefox has never had trouble with this site before late last night.

Okulungisiwe ngu wjbaldwin2

Isisombululo esikhethiwe

FredMcD said

I have several versions of Firefox and had no problem. Make sure you are not blocking content. [SNIP]

Thanks for the reply! It was cookies after all. I removed the jocolibrary cookies and thought that was all of them. But it was the bibliocommons ones that were causing trouble. I now see that there's that padlock to the left of the URL that will let me clear cookies and site data rather than hunting each one down in my settings and deleting them manually.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

I have several versions of Firefox and had no problem.


Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Isisombululo Esikhethiwe

FredMcD said

I have several versions of Firefox and had no problem. Make sure you are not blocking content. [SNIP]

Thanks for the reply! It was cookies after all. I removed the jocolibrary cookies and thought that was all of them. But it was the bibliocommons ones that were causing trouble. I now see that there's that padlock to the left of the URL that will let me clear cookies and site data rather than hunting each one down in my settings and deleting them manually.

Okulungisiwe ngu wjbaldwin2

more options

That was very good work. Well Done.