Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Suggestions Firefox provides

  • 4 uphendule
  • 1 inale nkinga
  • 9 views
  • Igcine ukuphendulwa ngu ca3scott

more options

Every time I enter a web address in the address bar, up pops two desktop options (even though I do not have my extra monitor connected any longer). I have to manually click on the desktop I want. Only then can I complete typing in the address. This is driving me crazy. I have turned off all 'suggestions' settings that I can possibly think of. I can find no way to turn this off. This never happened in any previous version of Firefox.

Every time I enter a web address in the address bar, up pops two desktop options (even though I do not have my extra monitor connected any longer). I have to manually click on the desktop I want. Only then can I complete typing in the address. This is driving me crazy. I have turned off all 'suggestions' settings that I can possibly think of. I can find no way to turn this off. This never happened in any previous version of Firefox.

All Replies (4)

more options

That seems very strange. Normally, when you submit a a URL, it opens in the same tab, or in a new tab in the active Firefox window. (But I run Windows, so there are some differences.)

Helpful?

more options

Thanks for writing. I know -- it is very strange. I have turned off all suggestions, and I still can't type a complete web address in -- a suggestions box opens at the bottom of the page and I have to manually close it before I can complete the address. I am starting to think that I may just have to switch to Safari. This is irritating me.

Helpful?

more options

The box about choosing a display is not part of the address bar drop-down, it is a separate dialog? Any chance you could screenshot it?

As you probably have noticed, search engine suggestions are not requested until you type the second letter into the address bar. If you start typing very slowly, does the appearance of the dialog seem to be associated with search engine suggestions? I guess you already tried disabling them on the Preferences page:

Helpful?

more options

Thanks you. I will try to send a screenshot the next time this happens.

I just restarted Firefox to see if perhaps that would fix it. I may try restarting the computer.

I did turn off search suggestions. As far as I can tell, I have turned off every kind of suggestion I can -- even helpful ones like filling in a bookmark, etc.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.