Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bing SafeSearch resets to Moderate

  • 3 uphendule
  • 1 inale nkinga
  • 184 views
  • Igcine ukuphendulwa ngu cjwilson

more options

Firefox keeps resetting Bing SafeSearch back to Moderate. This change occurs with every single search and the problem has only begun since in the last week to 10 days (it is now 1/21/2022.) I have cleared all histories and cookies and even gone as far as to completely reset my computer. It happens on all my PC computers, Win 10 and Win 11. It happens with all combinations of my Firefox profiles and all of my MS accounts. It happens when I'm not signed into any Firefox profile or Bing account. It happens in normal mode as well as private mode. It happens only with Firefox. It does not happen with Edge or Chrome. This is very clearly a conflict between Firefox and Bing SafeSearch.

Isisombululo esikhethiwe

Unfortunately, Bing has not caught up with a change in Firefox 96 that conforms some of its cookie handling to work like Chrome and Edge. According to someone who analyzed the site, Bing needs to modify its cookies for Firefox to be like the ones it sends to Chrome to make it work with the change: https://bugzilla.mozilla.org/show_bug.cgi?id=1750152#c19 (Note: please do not add comments to a bug unless you can help fix it.)

For now, try this (it worked for me in a test profile):

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

Firefox should list two matching preferences:

  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.laxByDefault.disabledHosts

(C) Double-click the network.cookie.sameSite.laxByDefault.disabledHosts preference to display an editing field, and enter www.bing.com and then press Enter or click the blue check mark button to save the change.

Can you save changes on Bing after that?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (3)

more options

Isisombululo Esikhethiwe

Unfortunately, Bing has not caught up with a change in Firefox 96 that conforms some of its cookie handling to work like Chrome and Edge. According to someone who analyzed the site, Bing needs to modify its cookies for Firefox to be like the ones it sends to Chrome to make it work with the change: https://bugzilla.mozilla.org/show_bug.cgi?id=1750152#c19 (Note: please do not add comments to a bug unless you can help fix it.)

For now, try this (it worked for me in a test profile):

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

Firefox should list two matching preferences:

  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.laxByDefault.disabledHosts

(C) Double-click the network.cookie.sameSite.laxByDefault.disabledHosts preference to display an editing field, and enter www.bing.com and then press Enter or click the blue check mark button to save the change.

Can you save changes on Bing after that?

Helpful?

more options

Worked so far .Thanks.

Helpful?

more options

Works for me too. Thanks!

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.