Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Icons have changed

  • 11 uphendule
  • 1 inale nkinga
  • 14 views
  • Igcine ukuphendulwa ngu wohikiv920

more options

I've recently noticed that some icons on websites are showing up as "asian" characters. I haven't knowingly changed any settings, gone to any strange sites, nor added any extensions. I've tried clearing the cache and even removed and reinstalled firefox and the few extensions I use, which are the common ones like adaware,etc. Nothing has seemed to work. The icons range from ones that link to facebook, twitter, etc to the search icon. If I inspect the icon it says the font is "MingLiU_HKSCS" I've checked the setting and it says the font is times new roman and even unchecked the box that says "Allow pages to choose their own fonts, instead of your selections above" but neither seems to work. Thanks for your help

I've recently noticed that some icons on websites are showing up as "asian" characters. I haven't knowingly changed any settings, gone to any strange sites, nor added any extensions. I've tried clearing the cache and even removed and reinstalled firefox and the few extensions I use, which are the common ones like adaware,etc. Nothing has seemed to work. The icons range from ones that link to facebook, twitter, etc to the search icon. If I inspect the icon it says the font is "MingLiU_HKSCS" I've checked the setting and it says the font is times new roman and even unchecked the box that says "Allow pages to choose their own fonts, instead of your selections above" but neither seems to work. Thanks for your help

All Replies (11)

more options

There is a big difference between those two!

On the Settings page, Fonts dialog, there is selector at the top for the character set (below the text "Fonts for"). Most of those pages would use the fonts specified for the "Latin" character set, but you could also check "Other Writing Systems" at the bottom of the list. It's best to keep the default setting of letting pages choose their own fonts.

That aside, icons more commonly are parts of a downloadable font supplied by the site, and if they are missing, it's more common to see a tall rectangle with two little rows of numbers. Do any of your add-ons block downloadable fonts?

Helpful?

more options

Make sure you allow pages to choose their own fonts.

  • Settings -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of your selections above"

If you use uBlock Origin make sure not to "block remote fonts".

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.


You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

more options

jscher2000 said

There is a big difference between those two! On the Settings page, Fonts dialog, there is selector at the top for the character set (below the text "Fonts for"). Most of those pages would use the fonts specified for the "Latin" character set, but you could also check "Other Writing Systems" at the bottom of the list. It's best to keep the default setting of letting pages choose their own fonts. That aside, icons more commonly are parts of a downloadable font supplied by the site, and if they are missing, it's more common to see a tall rectangle with two little rows of numbers. Do any of your add-ons block downloadable fonts?

Thanks for the info. I double checked and it appears nothing should be blocking the fonts. I also checked the settings you mentioned and have tried both letting the sites choose and not, and in both ways it keeps showing the characters.

Helpful?

more options

cor-el said

Make sure you allow pages to choose their own fonts.
  • Settings -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of your selections above"
If you use uBlock Origin make sure not to "block remote fonts". If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

I checked and letting sites choose fonts is still checked.

None of the extensions appear to block the fonts as you mentioned.

I have used the inspector tool as you suggested and that was how I figured out the font being used. So does that mean the site is specifying the font? If so, if I uncheck the "let sites choose the font" shouldn't that prevent the Asian characters from being used? As the other person mentioned, they aren't showing up as a tall rectangle with two little rows of numbers?

Helpful?

more options

Just to be sure:

Do you see a real character or a little box with the hex code of the character ?

The latter means that you do not have a font that covers this Unicode range or that the font that is used doesn't include those glyphs.

Helpful?

more options

Here are two pics of what I'm seeing. The first is mainly what I see, but I found the second on a page this morning.

The second one is what I believe the other person mentioned about the rectangle with the two rows of numbers. I've seen that before and realize that is most likely from adblocking software. the Asian icons are taking the place of links to things like facebook or instagram or even just site logos.

Helpful?

more options

Can you post a screenshot that shows how other browser display these characters or provide a link ?

How do these characters show in the Inspector as it is possible they use an icon font that maps on a Unicode range reserved for CJK ?

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

Helpful?

more options

I think I got back to the same page that it showed on the last time when I made the attached pictures.

I attached a couple screen shots of the items in the Brave browser, where they show up fine, without the added characters. Same with IE. 1 and 3 are the same and 2 and 4 are the same.

I also took some grabs of the inspector screen when I highlight those icons.

Thanks again for the help

Helpful?

more options

If you use the Inspector (F12) in Brave, what font is being used there for those two icons (or maybe they are emojis) above "All transactions are safe and secure"? Or are they images in Brave?

Helpful?

more options

Can you post the two characters above "All transactions are safe and secure" so we can select them and see check their Unicode representation (possibly the E000-EFFF range) ?

Helpful?

more options

I believe I posted the info you were both asking for.

Interestingly, I updated Firefox last night after I got these and now that its updated the icons don't show up at the asian characters, but as the tall rectangle with the numbers. I'm actually ok with that, as I believe that means something in either Firefox or an extension is blocking them. My biggest concern was why they were being changed into the characters.

Does that thought make sense?

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.