Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Default Display language

  • 2 uphendule
  • 1 inale nkinga
  • 7 views
  • Igcine ukuphendulwa ngu danost

more options

using firefox 95.0.1, 64 bit, on LInuxMint 20.2 I am in Israel, when I use google search, the result of the search opens in Hebrew display language. The only way I have found to fix this, to display in English, is to change my IP address to an English speaking country, e.g. the USA.

another browser, for example Brave based on Chrome, it always opens a google search result in English.

Please fix this ASAP

Thank you

using firefox 95.0.1, 64 bit, on LInuxMint 20.2 I am in Israel, when I use google search, the result of the search opens in Hebrew display language. The only way I have found to fix this, to display in English, is to change my IP address to an English speaking country, e.g. the USA. another browser, for example Brave based on Chrome, it always opens a google search result in English. Please fix this ASAP Thank you

All Replies (2)

more options

Sign in to Google. Go to its settings and select your language.

more options

My language is set to English, always has been for many years. Checked settings again now, still is English. in recent few versions of FireFox this problem exists.