On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to disable dark mode!?

  • 3 uphendule
  • 2 zinale nkinga
  • 1644 views
  • Igcine ukuphendulwa ngu Terry

more options

Hi! This will sound like an odd question, given that everybody seems to search for the opposite - but how could I DISABLE dark-mode in FF95.00?

I have my whole OS in dark-mode the whole time because of looks. I also installed a dark-mode theme on FF. Because of looks. But after the latest updates, FF decided to present a bunch of my favourite websites in dark-mode, too. Even at daytime - where I use my Computer.

Affected websites are, for example such "unknown" websites like "twitter.com", "spiegel.de" or even "facebook.com". It seems like they use some kind of a flag or token, which decides to use darkmode or not. How do I re-enable the light-mode (is this even a word?), not dependent of my windows / FF settings? Is there an add-on?

Hi! This will sound like an odd question, given that everybody seems to search for the opposite - but how could I DISABLE dark-mode in FF95.00? I have my whole OS in dark-mode the whole time because of looks. I also installed a dark-mode theme on FF. Because of looks. But after the latest updates, FF decided to present a bunch of my favourite websites in dark-mode, too. Even at daytime - where I use my Computer. Affected websites are, for example such "unknown" websites like "twitter.com", "spiegel.de" or even "facebook.com". It seems like they use some kind of a flag or token, which decides to use darkmode or not. How do I re-enable the light-mode (is this even a word?), not dependent of my windows / FF settings? Is there an add-on?

Isisombululo esikhethiwe

The default about:config setting was apparently changed in FF95 so that is the change you should make. https://support.mozilla.org/en-US/questions/1360536#answer-1465159

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Hey there!

Go to about:addons, then go to the themes sections on your left. Then disable the Dark Theme and enable the Light Theme.

Depending on your browser's theme, the site you visit will also be that theme color. Because your browser was on "dark-mode", the websites you visited (google, twitter, etc.) would be on "dark-mode".

Hope I helped!

Kind regards,

Bithiah

more options

It would probably be easiest to use the automaticDark extension and set it to change between a light theme during the daytime and a dark theme during the night.

You could also set the layout.css.prefers-color-scheme.content-override pref in about:config to 1 (0 - dark, 1 - light, 2 - system, 3 - browser). Then set the Dark Reader extension to come on automatically at night. That would allow a dark system theme, dark browser theme, light web pages during the day, and dark web pages at night. However, the about:preferences, about:addons, and such will be light color.

more options

Isisombululo Esikhethiwe

The default about:config setting was apparently changed in FF95 so that is the change you should make. https://support.mozilla.org/en-US/questions/1360536#answer-1465159