Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cannot play CNN live in browser

  • 6 uphendule
  • 1 inale nkinga
  • 19 views
  • Igcine ukuphendulwa ngu cjahn50

more options

When I try to play CNN live video in Firefox, I am prompted to choose my provider in a pop-up. When I click Spectrum I get a screen with this in the upper right hand corner - adobe-pass-2.60.0.4-8a55665.

What do I need to change or set to get the live stream to play?

FWIW - This works on Edge and Chrome.

When I try to play CNN live video in Firefox, I am prompted to choose my provider in a pop-up. When I click Spectrum I get a screen with this in the upper right hand corner - adobe-pass-2.60.0.4-8a55665. What do I need to change or set to get the live stream to play? FWIW - This works on Edge and Chrome.

All Replies (6)

more options

Can you post a screenshot? It works for me on Win11 with Comcast. see screenshot Have you tried in Safe Mode?

more options

This is what I get when I click on Spectrum in the providers list. And this is happening on windows 10.

more options
more options

I did try it in Troubleshooting mode. I got the same results. And the same message.

more options

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

I have/had done this one more than one occasion. The simple issue is that when I click on Spectrum to login to my provider, I get a screen with the message in the upper right hand corner and no login screen. As I mentioned, this is on Windows 10 20H2 and it works perfectly on Edge (all versions) and Chrome. In those browsers, I get the screen I see in Firefox briefly and then I am sent to the Spectrum site to login. In the case of Firefox, I get the screen and it hangs there.