Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Laptop Slowdown - Task Manager Shows Almost 100% Memory Usage

  • 2 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu FredMcD

more options

Hello - first I just want to acknowledge how great it is to have a free browser, and the great work the (un-or underpaid) Mozilla team has done lo these many years - thank you.

Okay, just want to put this out there but it seems sometime after version 90 of my Firefox browser I am seeing extreme slowdowns on my underwhelming Dell 5520 Inspiron laptop, circa 2014, running Windows 8.1. I also have Malwarebytes and Avast Premium Antivirus running together. My last Windows update was about two weeks ago (11 Nov 2021). My Firefox browser is currently 94.0.2.

I have noticed this four times. I typically browse Reddit but sometimes it's with Youtube. This is normally the scenario: 1) Launch browser; 2) navigate to website; 3) keep tab open for several hours and in many cases my laptop will go to sleep at least once; 4) at some point after waking up PC, logging in then continuing to browse, a warning banner in Firefox will tell me "This website is slowing your browser down. Stop it?", but if I wait at least 5 seconds it will automatically clear; 5) launch Task Manager - which is not easy because of what is going on but after 30-60 seconds it will appear; 6) notice that memory usage is extremely high and most processes are coming to a halt; 7) close Firefox and thing return to normal after 30-45 seconds. I've attached some before and after screenshots. The "before" is after browsing Reddit for about 3 hours and my laptop went to sleep twice; the "after" is when Firefox was closed (two tabs were open - one Reddit, the other Youtube) and then waiting about 30 seconds. Firefox instances take a little time to disappear from Task Manager, apparently.

Lots of variables to consider here: Latest antivirus program not working well? Extensions? (I have three extensions - Adblock Plus, Privacy Badger and Ecosia Search) Perhaps Firefox itself? Motherboard/DIMMs that is/are overdue for the landfill? Windows sucks? (rhetorical).

I guess I am not really looking for help but instead just want to log this as a heads-up to anyone who is encountering the same problem under the same conditions. I will continue experimenting with refreshing my instance of Firefox and possibly turning off browsers/antivirus components in a selective manner to see if it makes any difference. There is also the possibility that a Windows Update has broken something so maybe a restore point is in order here.

Thanks again for offering such a great product.

- Ngo

Ama-screenshot ananyekiwe

All Replies (2)

more options

It's more helpful if you provide the specs of your laptop from the performance tab. see screenshot Malware, Avast, and Defender.... sounds like a lot to me.

Okulungisiwe ngu jonzn4SUSE

Helpful?

more options

Having too many protection programs could cause issues.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.