On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Spelling checker not working

  • 2 uphendule
  • 1 inale nkinga
  • 55 views
  • Igcine ukuphendulwa ngu Richard240

more options

For a long time I have not had the spell checker working on Firefox.

For example, in this text box as I type now, I have no spelling correction. If I right click I have no option to check spelling.

In settings - language, I have check spellings as you type ticked. In Add-ons, Manague Your language I have English (GB) Language pack installed

I have read everything I can, yet still can't get spellings enabled.

I can run the portable app version of firefox and spellings work for that, and a right click in a similar box to this gives me spelling options, so I know what it should look like.

I would really appreciate any help.

Thanks

Richard

For a long time I have not had the spell checker working on Firefox. For example, in this text box as I type now, I have no spelling correction. If I right click I have no option to check spelling. In settings - language, I have check spellings as you type ticked. In Add-ons, Manague Your language I have English (GB) Language pack installed I have read everything I can, yet still can't get spellings enabled. I can run the portable app version of firefox and spellings work for that, and a right click in a similar box to this gives me spelling options, so I know what it should look like. I would really appreciate any help. Thanks Richard

Isisombululo esikhethiwe

Thanks FredMcD for your help.

layout.spellcheckDefault was/is set to 1 spellchecker.dictionary is set to Boolean

But googling what spellchecker.dictionary should be set to I came across

https://support.mozilla.org/en-US/questions/1294293 which contains the statement

"Note that the en-GB Firefox version doesn't come with a dictionary for licensing reason and you need to install the en-GB dictionary from the Add-ons website.

   https://addons.mozilla.org/en-US/firefox/addon/british-english-dictionary-2/ " 

Adding that dictionary cured the problem.

Thanks very much for the hint

Richard

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

more options

Isisombululo Esikhethiwe

Thanks FredMcD for your help.

layout.spellcheckDefault was/is set to 1 spellchecker.dictionary is set to Boolean

But googling what spellchecker.dictionary should be set to I came across

https://support.mozilla.org/en-US/questions/1294293 which contains the statement

"Note that the en-GB Firefox version doesn't come with a dictionary for licensing reason and you need to install the en-GB dictionary from the Add-ons website.

   https://addons.mozilla.org/en-US/firefox/addon/british-english-dictionary-2/ " 

Adding that dictionary cured the problem.

Thanks very much for the hint

Richard