On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to disable history search box within website

  • 5 uphendule
  • 1 inale nkinga
  • 67 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hello, i'd like to disable this function in Firefox (see image). it seems if i typed something on the text box (not history in search bar) Firefox will automatically save the text i typed. I have searched the web but i can't find the spesific options in my case, the only similar thread i find here are this https://support.mozilla.org/en-US/questions/1281693 but even there the issue aren't solved yet. Thank you!

Hello, i'd like to disable this function in Firefox (see image). it seems if i typed something on the text box (not history in search bar) Firefox will automatically save the text i typed. I have searched the web but i can't find the spesific options in my case, the only similar thread i find here are this https://support.mozilla.org/en-US/questions/1281693 but even there the issue aren't solved yet. Thank you!
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

You can disable remembering saved form data via "Settings -> Privacy & Security".

  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history": "Remember search and form history"
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

I forgot to mention the website in screenshot are https://www.db.yugioh-card.com/yugiohdb/card_search.action (Official Yu-Gi-Oh! Card Search website).

more options

If that is a function of the website, you may not be able to alter it. I would try using 'History' settings on the Privacy page of Settings. Use 'custom' settings and select only "Remember browsing and download history".

more options

That is the website's search engine. Not Firefox.

more options

@Tnorth i see, thanks for the suggestion.

@FredMcD it's not, (look at images below) this was from the ask forum in this website and see? there's another history for it, I can show you a bunch of other websites that have this similar problem. Seems like Firefox didn't have any feature to disable it.

I have been using Firefox for 2 weeks now, i'm migrated from Chrome btw and Chrome has the feature to disable it with chrome flags.

more options

Isisombululo Esikhethiwe

You can disable remembering saved form data via "Settings -> Privacy & Security".

  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history": "Remember search and form history"