Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable certificate verification

  • 2 uphendule
  • 1 inale nkinga
  • 1484 views
  • Igcine ukuphendulwa ngu cor-el

more options

I can't seem to disable the certificate verification on Mozilla Firefox. As you can see on the screenshot, the error code is SEC_ERROR_UNKNOWN_ISSUER.

I tried multiple solutions, including :

- https://smallbusiness.chron.com/disable-firefox-rejecting-certificates-59249.html - The three solutions from https://stackoverflow.com/questions/20088/is-there-a-way-to-make-firefox-ignore-invalid-ssl-certificates - https://support.mozilla.org/en-US/questions/1234483 - All of the solutions from https://browserhow.com/how-to-fix-mozilla-firefox-ssl-certificate-error/ - https://itectec.com/superuser/how-to-make-firefox-ignore-all-ssl-certification-errors/

and so on.

Is there a way to disable this for only one website, or at least for all website ? I got a web interface which is self signed (if I understand everything correctly) where we can bypass the certificate "error" but it would be great if I just could configure Firefox to skip it entirely for this interface (as I'm certain it's not insecure and even if it was I'd still use it because I can't use anything else for now.

I know Chrome has a command line which do exactly what I want (--ignore-certificate-errors) but Firefox is a must go for me so I'd prefer to find an option on this browser.

Thank you for your time.

I can't seem to disable the certificate verification on Mozilla Firefox. As you can see on the screenshot, the error code is SEC_ERROR_UNKNOWN_ISSUER. I tried multiple solutions, including : - https://smallbusiness.chron.com/disable-firefox-rejecting-certificates-59249.html - The three solutions from https://stackoverflow.com/questions/20088/is-there-a-way-to-make-firefox-ignore-invalid-ssl-certificates - https://support.mozilla.org/en-US/questions/1234483 - All of the solutions from https://browserhow.com/how-to-fix-mozilla-firefox-ssl-certificate-error/ - https://itectec.com/superuser/how-to-make-firefox-ignore-all-ssl-certification-errors/ and so on. Is there a way to disable this for only one website, or at least for all website ? I got a web interface which is self signed (if I understand everything correctly) where we can bypass the certificate "error" but it would be great if I just could configure Firefox to skip it entirely for this interface (as I'm certain it's not insecure and even if it was I'd still use it because I can't use anything else for now. I know Chrome has a command line which do exactly what I want (--ignore-certificate-errors) but Firefox is a must go for me so I'd prefer to find an option on this browser. Thank you for your time.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

You will probably have to click the button to accept the certificate and continue with this self-signed certificate.

You can try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options
  • MOZILLA_PKIX_ERROR_MITM_DETECTED
  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly

How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

more options

Isisombululo Esikhethiwe

You will probably have to click the button to accept the certificate and continue with this self-signed certificate.

You can try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).