Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Update 94.0 & 94.0.1 Windows 10 not loading lots of sites

  • 11 uphendule
  • 1 inale nkinga
  • 19 views
  • Igcine ukuphendulwa ngu Timespider

more options

Hello, I'm on windows 10 & updated to 94.0 then 94.0.1 but both updates are either very slow loading of some sites or it won't load the page/site at all. I've used FF for years & never had an issue. I disabled all extensions (did it manually & through FF troubleshooting mode) & antivirus but the same thing happens. I'm at my wits end & have swapped my main browsing to Edge & just gathering all my extensions for that browser.

Just trying to find help is now a nightmare.

How can I go back to the previous version before the 94.0 update?

Regards Chris

Hello, I'm on windows 10 & updated to 94.0 then 94.0.1 but both updates are either very slow loading of some sites or it won't load the page/site at all. I've used FF for years & never had an issue. I disabled all extensions (did it manually & through FF troubleshooting mode) & antivirus but the same thing happens. I'm at my wits end & have swapped my main browsing to Edge & just gathering all my extensions for that browser. Just trying to find help is now a nightmare. How can I go back to the previous version before the 94.0 update? Regards Chris

All Replies (11)

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Hi FredMcD,

I have cleared history (everything from all time) cache cookies etc. Issue still there

Issue still there in safe mode.

I don’t know what this means “Make sure you are not blocking content” Can you explain what you mean and what I need to do.

I’ve spent a week on this & I’m getting nowhere.

Also to add to this here’s a screenshot of one of the pages plus if you look up at the tabs you’ll see there’s 3 that won’t load.

Regards Chris

more options

Did you check out the links I posted under 'Make sure you are not blocking content' ?

more options

Yes but I don't really understand what it means. I've attached a screenshot of the error & the other tabs that won't load, sometimes a lot sometimes just a couple. It'll be coming up a couple of weeks & no solution. It literally updated I closed the browser & reopened it & this all started, nothing changed bar the FF update, the first 94.0 but the same in 94.0.1.

Also it's a lot slower now when it does work.

I think I'll have to remove FF and after years of supporting it use something else like Edge as this seems like it won't be fixed..

Okulungisiwe ngu Timespider

more options

You should have posted the error message before.

‘ssl_error_rx_record_too_long’ or ‘cannot display the webpage’ Internet search; More often than not, you have something misconfigured!


Use these links to create a new profile. Use this new profile as is. Is the problem still there?

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles


Type about:profiles<enter> in the address bar.

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

I tried post the error image twice before both in FF and edge but this page wouldn't let me. I'll let you know how I've got on in a day or so. Thanks

more options

Well it hasn't taken a day and it's still happening. Done safe mode using this https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ I've created a new profile and lost all my old settings. I have done all the proxy stuff, even in the new profile.

It's still happening. I feel like I'm just wasting my time.

How can the update change FF from working fine for years to a pile of junk in one foul swoop?

more options

Hii Timespider, i undertand your problem please update your firefox steps Click the menu button in the top right corner. Click the Help button. Select About Firefox. Click Check for updates. Click Update. Click Restart Firefox to Update. Thanks Regards -Arman

more options

Hi ARMAN KHAN, there is no check for updates as its up to date. Image attached.

I can't even login to anything of like anything in FF.

Thanks

Okulungisiwe ngu Timespider

more options

Well I've abandoned FF after years & years. Weeks have gone by and no solution, it's a shame as I like it, but I can't waste my time anymore.

As I said earlier, I can't understand how in one update it's either changed settings I don't know about or has a bug FF team doesn't know about.