Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop all installed firefox extensions from loading their mainpage after syncing?

  • 1 baphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu jscher2000

more options

How do I stop all installed firefox extensions from loading their main page after syncing?

every time I sync from a different computer or version of windows all the extensions load up their main author page all at the same time overtaking my browsing session so that I have to manually close each tab

its very frustrating On a side note Also after unnecessarily refreshing firefox and before manually changing proxy settings to "no proxy" after each refresh (Why is no proxy not the default setting anymore?) why was every webpage blocked and needing a security certificate? even google.com? and not long ago firefox crashed every tab, constantly, it wasnt even usuable but Im so dependant on its features I tolerated it but cant afford to much longer I have to use Chrome for my business as firefox doesnt always capture login/password for autologin nor for address, etc -fill in

All Replies (1)

more options

keneglinton said

How do I stop all installed firefox extensions from loading their main page after syncing? every time I sync from a different computer or version of windows all the extensions load up their main author page all at the same time overtaking my browsing session so that I have to manually close each tab

I have not heard of this before. Most extensions do not store their settings in Sync storage, so in determining whether to show you a "new user" page, I suspect local extension data storage would be more important.

On a side note Also after unnecessarily refreshing firefox and before manually changing proxy settings to "no proxy" after each refresh (Why is no proxy not the default setting anymore?) why was every webpage blocked and needing a security certificate? even google.com?

The default behavior at installation has always been "Use system proxy settings" at least on Windows. Also, by default, Firefox uses its own separate certificate store. Whether that combination of settings causes problems depends on your environment.

If the proxy is supposed to be running in your environment, for example, a corporate proxy server, then you can either:

(A) Set Firefox to rely on the system certificate store instead of its own - presumably the proxy server's signing certificate (used to dynamically generate fake site certificates) is already in there or your other browsers wouldn't work (security.enterprise_roots.enabled => true in about:config); or

(B) Import the proxy's signing certificate into Firefox's certificate store (more work, but then you can decide on a case-by-case basis which certificates to trust).

If the proxy is a man in the middle that isn't supposed to be there, you need to find a way to remove or bypass it. Setting No Proxy is one method for bypassing it if you can't track down the miscreant.

I have to use Chrome for my business as firefox doesnt always capture login/password for autologin nor for address, etc -fill in

If you notice a pattern to this, you could file a bug: https://bugzilla.mozilla.org/

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.