Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

problem with text/font size on some websites since computer reset

  • 9 uphendule
  • 1 inale nkinga
  • 27 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I had to do a computer reset on my laptop back to factory settings, everything ok now except one annoying issue I cannot seem to resolve. Some websites I was using perfectly ok in Firefox before now show as tiny text/font size and or generally looks wrong (in firefox) and nothing I do seems to resolve the issue, for example I'm viewing some websites at 130% but some text on the page is still too small. I can view the same sites in chrome with no issues at all at normal 100% level, The best example I could give I can't paste here for obvious reasons, my hargreaves lansdown pension values text is all squashed together so individual text that shows on one line on chrome (correctly) shows as condensed into 2 lines in firefox, the text is big but the values beside it are not for example, any increase in the zoom level doesnt really resolve this issue, yes the text gets bigger but I shouldnt have to read it at 150% zoom !!! but 100% is waaay too small, and the values size is not in sync withe the text beside it. I count myself as fairly savvy technically, I've tried all sorts including clearing cache and cookies and checking settings etc in firefox but this one has me stumped, some sites work ok but it looks like Firefox may be struggling to cope with some sort of display extension that some sites are using to display some parts of their page Any ideas please ? Thanks

Isisombululo esikhethiwe

Can you attach a screenshot?


You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (9)

more options

[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Helpful?

more options

no sorry that hasnt resolved my issue, I do however have another laptop where I can compare the fonts and Firefox settings and they are the same, iits occurred to me that it all displays ok on the other laptop so I'm thinking it must be a problem within the OS settings, given that in mind could you/someone direct me to something that may be amiss there please so that I can compare against those settings also ? Thanks

Helpful?

more options

threeputt1 said

. . . so I'm thinking it must be a problem within the OS settings

FredMcD said

Make sure you haven't enabled a High Contrast theme in the OS settings.


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

Helpful?

more options

Helpful?

more options

" Use these links to create a new profile. Use this new profile as is. Is the problem still there?"

Interesting, I created the new profile and this appeared to resolve the issue when I reloaded Firefox with the new profile. I noticed I now have 3 profiles (there were 2 there already) 1. is the faulty display profile I have been using since reset by the look of it 2. I dont know what this one is but its an empty profile (much like 3.) and websites appear to display ok 3. this is the newly created profile I created from the instructions (and looks very much like 2.) and websites appear to display ok

1. Profile: default-release This is the profile in use and it cannot be deleted. Default Profile yes Root Directory C:\Users\rober\AppData\Roaming\Mozilla\Firefox\Profiles\ng9nlp1v.default-release Local Directory C:\Users\rober\AppData\Local\Mozilla\Firefox\Profiles\ng9nlp1v.default-release

2. Profile: default Default Profile no Root Directory C:\Users\rober\AppData\Roaming\Mozilla\Firefox\Profiles\toggc4pw.default Local Directory C:\Users\rober\AppData\Local\Mozilla\Firefox\Profiles\toggc4pw.default

3. Profile: profile number 2 Default Profile no Root Directory C:\Users\rober\Desktop\test number 2 folder

Is there a way I can compare settings on these to resolve the issue on 1. above (as I'd prefer to keep using 1. above rather the pain of setting firefox all up again)

Thanks, looks like I might be getting somewhere even if I eventually have to go through the pain mentioned above :)


The below questions may of course now be redundant !

 "Make sure you haven't enabled a High Contrast theme in the OS settings." - I had to reset my laptop to factory settings (thats when I found the issue) and as far as I am aware I havent changed these, but maybe you could point me to them


"Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?"

I started in safe mode with network support but of course no internet connection then to test with and no alternative that I know of

Helpful?

more options

Isisombululo Esikhethiwe

Can you attach a screenshot?


You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

more options

I compared profiles, the faulty profile was set to a default of a font of size 10 and I unticked the 'zoom text only' option (although this was something I personally tagged when I was trying to originally resolve the issue). Pretty sure I checked these settings against my other laptop but hey ! I think these were the only 2 settings I had to change in the end but it worked when I rebooted the browser.

Thanks for all of your help on this, I've certainly learned some new stuff, the add profile option is definitely something that could be of use to me in the future and is new to me

Helpful?

more options

Note that using "Zoom Text Only" can cause issues on websites that use absolute positioning or containers that have fixed size (text can overlap or can get cut off). Increasing the default minimum font size can cause similar issues. Best/safest is always to use full page zoom and possibly set a higher default zoom.

Firefox has a Zoom section in Settings to set the default zoom level for webpages.

  • Settings -> General -> Language and Appearance -> Zoom

Firefox has a global zoom that affects the user interface and webpages that can be adjusted by modifying layout.css.devPixelsPerPx from its default of -1 to 1.0 on the about:config page. Adjust its value in 0.1 or 0.05 steps (1.1 to enlarge or 0.9 to reduce) until icons or text looks right. Make sure not to use values too large or too small.

  • modifying layout.css.devPixelsPerPx affects user interface and webpages (global zoom)

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Helpful?

more options

There is also, https://addons.mozilla.org/en-US/firefox/addon/nosquint-plus/ NoSquint Plus by Baris Derin

Manage site-specific zoom levels and color settings

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.