Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TB 91 not retaining settings on restart

  • 20 uphendule
  • 1 inale nkinga
  • 64 views
  • Igcine ukuphendulwa ngu sreigle

more options

Steps to reproduce:

Changed settings: Sort by --> threaded Layout --> messenger pane off Start at --> Inbox (which is gmail)

Actual results:

Next restart of TB returns those settings to their default. Changes retained only until restart, then back to defaults. TB 91.2.0 Windows 10 Pro on HP laptop Have used TB for many years. Did not realize auto-update was on (didn't used to be on). Have now turned it off again. This change to updates was retained.

Expected results:

Should have retained those changes on restart.

Isisombululo esikhethiwe

If you change mailnews.default_view_flags to 1 (threaded), all new folders should be threaded. To make an existing folder threaded, Repair Folder from the Properties context menu. To apply it to all folders, delete the .msf files (which is equivalent to Repair Folder) from the profile, with TB closed. It's probably easier to delete multiple ,msf files than to Repair Folder for each folder.

https://www.badpenguin.org/thunderbirds-default-sort/

https://newbedev.com/change-the-default-sorting-order-in-thunderbird

https://bugzilla.mozilla.org/show_bug.cgi?id=86845#c74

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (20)

more options

Help/More Troubleshooting, Profile Folder, Open Folder, close TB, delete session.json. Does the layout now stick between restarts?

Helpful?

more options

Thank you for the reply. There is no session.json file in that folder. The closest is sessionCheckpoints.json. Attached is a snapshot of the files surrounding where session.json should be... I did get to the profile folder using the Help/More Troubleshooting, Profile Folder, Open Folder button.

I previously posted in the bugzilla area and they asked me to post here. First, they also told me to do as you did but also to delete xulstore.json. That file does exist. When I deleted it, then reset all my settings, closed TB and restarted, the only setting retained (of those I listed) is the sort by/threaded. That one now seems to be holding. All the others, however, were not retained.

Also, add Quick Filter Off as another not retained (defaults to ON).

Other ideas?

Helpful?

more options

Every TB profile that I have has a session.json file and some also have a session.json.backup file. I don't know why TB isn't creating one when TB is closed. If you create a new profile from Help/More Troubleshooting, about:profiles, then close TB and open the new profile folder, do you see the file?

Helpful?

more options

Before I create a new profile.... will I be able to get back to my current profile without having to re-enter all that info? Thanks.

Helpful?

more options

Yes, the current profile is unaffected, and either profile can be launched from about:profiles.

Helpful?

more options

Yes, I do see session.json in the new profile folder.

Helpful?

more options

You can transfer local mail, address books, calendars, filters etc. from the old profile to the new one if the settings issue is a nuisance. A secondary benefit is that the new profile will probably be much less prone to problems, given that your current profile has files that were created in older versions of TB. Experience has taught me to create a new profile with every major release, to avoid the inevitable upgrade issues that are presented every day on this forum.

Helpful?

more options

Can I also transfer account settings, layout and other settings or do I need to set them from scratch (in which case I need to go through them and make good notes or screenshots, plus find some time to do it!).

Hint on how to best transfer everything from old profile to new?

Thanks.

Helpful?

more options

You have to add the accounts again, which shouldn't be difficult. IMAP accounts will re-download from the server, while for POP accounts and Local Folders it's a matter of copying the mbox files from Mail/<popserver> and Mail/Local Folders to Mail/Local Folders in the new profile (mbox files are the large files with no extension, named after folders, and listed with like-named .msf files). Layout can't be copied, but again, this is a simple task. Export address books to LDIF and import to the new profile. Export local calendars to ics and import.

There is a partly outdated article on transfers:

http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Thunderbird

Helpful?

more options

Thanks again. I will give that a try. It may be a couple of days before I can do this. Or even several days. Very full plate for the next several days.

Will report back when I get that done. Hope they keep this open for a little while.

Helpful?

more options

Did the new profile. Set the settings. Closed TB. Restarted TB. It retained the settings!

Bonus - I can now connect to my google calendar! Before, it wouldn't allow me to even try. Just showed an empty calendar with everything grayed out that was needed to add the calendar. My local calendar is apparently gone but that's ok, I've already moved everything to Google Calendar anyhow.

Have a couple of relatively minor issues. If you can help with these, I'd appreciate it. If not, then you can close this one. Thank you very much for your help!

The issues: 1. My replies to emails are not showing in the thread. Only incoming show there.

2. No horizontal lines between emails.

3. Was unable to copy all my subfolders (sub to Inbox) to the new profile. Suspect the reason is that I decided to go imap to better sync between laptop, phone, and ipad. Previously was pop3. So, was able to launch the old profile simultaneously with the new one so can put the side-by-side and will create the folders on the new profile. I can drag emails from the old profile to the new but only one email at a time. Trying to drag multiple emails results in the "no" symbol, the circle with the line through it. I have many to copy so this will take time but is doable.

Thanks again for your help. You are a life saver.

Helpful?

more options

1. Not sure about this. Do you mean right-clicking a received message, Open Message In Conversation, isn't showing the received and sent messages in the same thread? That requires that Global Search is enabled in Preferences.

2. Horizontal lines in the Threads Pane (message list) aren't shown by default, but it's possible with userChrome.css.

3. Are you trying to copy from a local folder to an IMAP folder? That usually doesn't work except with small numbers of messages (exception), and it's best to first copy from the old profile to File Explorer by drag and drop, then drag and drop from FE to Local Folders in the new profile, then from LF to the IMAP folder.

Helpful?

more options

First, a new oddity. Sent messages in the Sent folder are bold as if unread. I've not seen that before in the Sent Folder. Plus, every sent message is shown in two Sent folders. See attached jpg. Note I have set the retention on the second Sent box to just retain 1 email.

Also, mail is showing up in the All Mail folder as well as the Inbox. Deleting from Inbox does not delete them from All Mail. Is there a way to stop them from going to All Mail or is that something I have to live with and clear out now and then now that I'm using imap?

1. Sent emails not showing in threads. Let's say you send me an email, I reply. You reply to mine. I reply again. In the past I would have seen four emails in that thread, two from you and two from me. Now I see only yours. Mine are in Sent, not in the thread in the Inbox like it used to be.

2. I think I copied and used the css in my earlier profile. I googled and found the css code so will do that soon. Thanks.

3. moving folders. The prior profile was pop3. I had numerous subfolders that were sub to the Inbox folder, not to Local Folders. New profile uses imap. Want to copy those subfolders from the old pop3 profile to the same location (sub to Inbox) on the new imap profile. Copying folders from the old profile's Mail folder to the new profile's Mail folder did nothing. I will try using the drag to Explorer method but there are numerous folders with email with identical subject lines. When I have copied multiple emails to Explorer in the past it won't let them use the same name, which is based on the subject. Will try again but doubtful that will work. At this point I have two instances of TB displaying, one with the new profile, one with the old (used Launch Profile from More Troubleshooting). Cannot drag the folder so am recreating the subfolder name on the new profile and then dragging one email at a time from old profile to new. It will not allow dragging more than one even though I can select multiples.

Does any of this make sense?

Thanks again.

Steve

Helpful?

more options

Since this is a gmail account, with All Mail, most users unsubscribe All Mail, as it contains mail from all other folders. See the All Mail section here.

Gmail automatically copies sent messages to Sent Mail, so uncheck 'Place a copy in' in Account Settings, Copies & Folders. Unsubscribe the other Sent folder. If you had sent messages in the Inbox, it must have been with an add-on like Conversations; it's not standard with any provider.

For deleting mail, use 'Just mark it as deleted' in Server Settings, according to gmail's recommendation.

To activate css, toggle toolkit.legacyUserProfileCustomizations.stylesheets to true in Config. editor.

Uploading from POP folders to IMAP folders has the same constraints as copying from Local Folders, as both are copying local mail. As mentioned above, you must copy POP or Local Folders mbox files from the old profile to Mail/Local Folders in the new profile, with TB closed, then copy limited numbers from LF to an IMAP folder through the TB interface.

Helpful?

more options

After reading about All Mail at the link you provided I decided to keep it since there is not a second copy of the emails using space. Plus, archived items are there.

Threads are now working correctly. Not sure why it didn't before.

Now have unchecked so not keeping the extra copy in Sent. Unsubscribed the second Sent folder.

Toggled the stylesheets setting in Config Editor. Where do I find the chrome folder and userChrome.css file to add the css? It's not in the profile folder. Maybe if I close TB first? Or do I need to create the folder and file per that link you gave me?

Your idea of using Explorer to copy emails is working well so far. Sure beats copying them one email at a time. If duplicates is a problem I'll deal with that when it happens. Copying the mbox files didn't work so will just do this one manually. Hopefully I won't run into further issues with this one.

Hope to hear about the css. It just dawned on me to check the prior profile for the css file since I had this working once before.... Found the chrome folder in the old profile. Looked at the css file and it looks good plus does another thing I forgot I liked. when a collapsed thread has an unread email it bolds the email that is displayed at the top of the collapsed thread. Here is the css if anyone is interested: /*

  • Do not remove the @namespace line -- it's required for correct functioning
*/

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* set default namespace to XUL */

/*

   * Collapsed read thread, but the thread contains unread , set text to bold black 
  • /
  treechildren::-moz-tree-cell-text(container, closed, hasUnread, read) {
    text-decoration: none !important;
    font-weight:  bold !important;
    color: #000000 !important;
  }

/*

   * If thread selected when containing an unread emal, set text color to black
  • /
  treechildren::-moz-tree-cell-text(container, closed, hasUnread, read, focus, selected),
  treechildren::-moz-tree-cell-text(container, hasUnread, read, focus, selected) {
    color: #000000t !important;
  }

/*

   * Add solid or dashed to Message pane
  • /
 treechildren::-moz-tree-row {
   border-bottom: 1px solid #66FFFF !important; 
}

/*

  Color on alternating lines in inbox - disabled this. can't tell when colored line is selected.
#threadTree treechildren::-moz-tree-row(odd) {
      -moz-appearance: none !important;
      background-color: rgb(232,232,232) !important; }
  • /

Helpful?

more options

The chrome folder and the css file have to be created manually. You can just copy the chrome folder from the old profile to the new one.

Helpful?

more options

That worked. Thanks.

Helpful?

more options

I'm trying to set the default view/sort by to Threaded for all existing folders and new folders. Google shows a few examples using config editor but none seem to work for me. Any idea how to make this the default? Thanks.

Helpful?

more options

Isisombululo Esikhethiwe

If you change mailnews.default_view_flags to 1 (threaded), all new folders should be threaded. To make an existing folder threaded, Repair Folder from the Properties context menu. To apply it to all folders, delete the .msf files (which is equivalent to Repair Folder) from the profile, with TB closed. It's probably easier to delete multiple ,msf files than to Repair Folder for each folder.

https://www.badpenguin.org/thunderbirds-default-sort/

https://newbedev.com/change-the-default-sorting-order-in-thunderbird

https://bugzilla.mozilla.org/show_bug.cgi?id=86845#c74

Helpful?

more options

Looks like I'm in pretty good shape now. You can close this incident.

TB wants to install 91.2.1 but I'm holding off on it until I'm comfortable it is stable and not buggy. I've read negative comments about that.

Thanks again.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.