Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird display colors gone

  • 7 uphendule
  • 1 inale nkinga
  • 25 views
  • Igcine ukuphendulwa ngu marktierno

more options

Just installed Thunderbird v91.2 and it seems to have nuked my display colors. Before I had the colors set up for the Write display window, the message display, and everything else. Now, everything's white. Preferences has no Display tab with which to set colors, a couplke of settings I found that control some color options do nothing, I've tried the Advanced Preferences and found one browser display set to #000000 and so set it to something else but that does not display and after a reboot that setting is still back to #000000 again. It seems as Thudnerbird has made it increasingly impossible to get its display to look like what i want. In color. The colors that I want. Themes are useless because there's only LIght and Dark now. Is there some sacrifice I have to make to the elder gods or something? I even tried backing up a couple of revisions but the colors are still gone (and I just had them 2 days ago), which tells me that maybe some preferences file got overwritten?

Isisombululo esikhethiwe

Well, seems to be holding steady now for being fixed (whatever caused it in the first place then cured it is still a mystery), so I'm marking this closed.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

Thunderbird has never had a display panel for setting colours. Did you perhaps use an addon in the past? or an external style sheet.

Helpful?

more options

many many moons ago Thunderbird had some means of allowing one to set colors in the Read window, the email lister window, and the email Write editor. then a revision came and that went away. Then I found some means of getting it back and was happy (It was either some sort of preferences setting or something on the advanced page, I forget exactly) and it stayed that way for many a revision. Now suddenly I'm back to staring at a lot of white, my colors gone. I tried backing up a revision or two but what was once there before is still gone. I looked up on the forums and they kept mentioning a Display tab in the Preferences page, but no can finds (Maybe that applies to PC only?). At any rate, I had color before and can't get it back. I even tried setting one of the variables on the Advance page from white to something else but it didn't stick.

Helpful?

more options

What OS are you using?

re : I tried backing up a revision or two Please confirm you are using the current release 91.2.0

The Light or Dark themes have been around for quite a few releases. Addon themes are limited because they are created by other users and not Thunderbird.

Some colours can be introduced. Phoenity Buttons 4.1 https://addons.thunderbird.net/en-US/thunderbird/addon/phoenity-buttons/

Folder Pane: All the icons can have a colour applied manually - right click on folder and select 'Properties' to see where to set the colour. However, you could use some 'userChrome.css' code to use auto set colours on current icons OR even reintroduce the old icons. I have supplied all three options at the following link, note the person who asked the question selected the options to have auto colours eg: junk will always be orange and sent always green in all accounts. Read all info as there are three options - I've included a couple of images below showing what the two types of code can produce.

Please note some changes in version 91* : Instructions that say: 'Menu app icon' > 'Options' then use 'Menu app icon' > 'Preferences' 'Help' > 'Troubleshooting Information' then use 'Menu app icon' > 'Help' > 'More Troubleshooting Information' Otherwise all info, code etc is identical and still working perfectly ok in version 91*

If you want to apply colour to a specifc area, then you need to post an image with arrows pointing to the areas eg: Green here So we can try to devise some css code.

re: I looked up on the forums and they kept mentioning a Display tab in the Preferences page, That was for some older versions and sounds like you are talking about font colour. Those options are still available, but you need to offer a lot more info on what you are trying to achieve before altering things as some choices may cause other issues. Menu app icon > Preferences > General > scroll down to 'Language & Appearance' click on 'Colours' Ideal settings are shown in the image below.

I've included some images to show what different folder icons can look like etc and yes, I'm using the dark theme in version 91*

Helpful?

more options

re :many many moons ago Thunderbird had some means of allowing one to set colors in the Read window, the email lister window, and the email Write editor.

Helpful info: Conventional names for various areas in UI as it helps to use a common lingo. On the left is the 'Folder Pane' containing mail account folders. On the right in upper half is the 'Thread Pane' it contains list of incoming emails. On the right in lower section is the 'Message Pane'. A single click on an email in the 'Thread Pane' will open and display email contents of selected email in the 'Message Pane'.

Helpful?

more options

Hitting Colors on Language and Appearance was the firsat thing I tried, and nothing I do with setting the Text and Background ever seems to affect anything in the message pane or any other pane. And yes, I've tried it with both Always and Never.

I went back up to 91.2, since even when I backed up a version or two the problem is still there now.

I've also just installed Quote Colors but it has very limited effect (compared to what it's supposed to do). Basically, at this point nothing seems to bring in some color to the Message Pane or Write editor, whereas before I had somethign besides just all white.

Helpful?

more options

The problem appears to have solved itself? Not for the first time I went back to Preferences--> Languages & Appearance, selected colors to check that- as before- the color I'd specified for the Background was styill there though it was being ignored in the actual display, switched the override switch from Always back to never (I'd tested both settings time and again before), hit okay, then next I look at my message pane the background color is back. As it is in the Write pane of a new email I tried to write as a test. Not to mention some formatting issues of how some old emails in my inbox were displaying also corrected. I am at a loss to explain what I did right just as I'm still not sure what went wrong in the first place. Problem... solved?

Helpful?

more options

Isisombululo Esikhethiwe

Well, seems to be holding steady now for being fixed (whatever caused it in the first place then cured it is still a mystery), so I'm marking this closed.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.