Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox problem with Paypal. It shows multiple question marks instead of words at the login and transactions.

  • 4 uphendule
  • 1 inale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu info6187

more options

Hello, My problem is that every time I go to log in to my PayPal account or work with some settings I get multiple question marks instead of words/letters. (see Screen Shot: https://jmp.sh/EYpj4pJ ) It only happens with the Firefox browser.

I have done what Firefox support recommends for troubleshooting, such as: Turn off extensions, reset preferences, restart, Start Firefox in Safe Mode, delete PayPal cookies, and clear cache. I also tried to disable hardware acceleration but, this doesn't apply to this version because it's not there (see Screen Shot: https://jmp.sh/wEZqkcP) but, the problem continues.

I already talk to PayPal Support because It only happens when using PayPal. They say that this is a Firefox problem since it works fine in other browsers.

I ask: Is there a problem between PayPal and Firefox that I should know about?

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

I appreciate the help you have given me to solve the problem. Here is what I did:

(1) I followed your suggestion by doing the three steps but it did not work for me despite using the reload button and restart Firefox. The problem continued. (At the end I switch the preference value back to true again).

(2) Thanks to the fact that you indicated that the problem could be with the HelveticaNeue font file(s), it occurred to me to check my font management app (Typeface). There I see that I have many varieties of the Helvetica family fonts activated and that could be creating a conflict.

(3) I disabled all the fonts that were enabled so that only the Mac system fonts were enabled.

Now the PayPal page is finally working! Thank you so much for guiding me to find the solution.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

The "question mark in a box" indicates that Firefox is having a problem displaying the font normally used.

For the blue "Next" button, the site instructs the browser to use this fonts (if one is not available, the browser should use the next one in the list):

pp-sans-big-medium, Helvetica Neue, Arial, sans-serif

That first one would be something Firefox downloads from the site. The others would be fonts on your system.

What I can't tell is which font your Firefox is trying to use. To investigate that, right-click (one button: Ctrl+click) the problem text and choose Inspect (Q).

Firefox should open the Developer Tools panel to the Page Inspector, and highlight that paragraph in the HTML "tree".

On the right side will be one or more panels of information about the highlighted element. Switch to the Fonts panel, which may require using a little triangle at the end of the row after Layout Computed Changes. Please see the attached screenshot.

What font does your Firefox show as being used for those characters?

Helpful?

more options

Thanks for responding. I think what you point out about the problem makes sense. The font Firefox is using is HelveticaNeue. In the panel next to it are these fonts: HelveticaNeue-Medium, "Helvetica Neue Medium", HelveticaNeue, "Helvetica Neue", Helvetica, Arial, sans-serif;

I am attaching the screenshot which shows several things crossed out or with a caution symbol next to it, just in case that helps.

Helpful?

more options

Thanks! The system is substituting the .LastResort font for some reason. This could indicate a problem with the HelveticaNeue font file(s), or it might be an issue with Firefox's ability to access it.

In another thread, a user disabled a particular feature and you could test this same workaround:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste layout.css.font-variations.enabled and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Does that make any difference (probably you need to Reload the page, using the Reload button or Command+R)?

More info on about:config: Configuration Editor for Firefox.

Helpful?

more options

Isisombululo Esikhethiwe

I appreciate the help you have given me to solve the problem. Here is what I did:

(1) I followed your suggestion by doing the three steps but it did not work for me despite using the reload button and restart Firefox. The problem continued. (At the end I switch the preference value back to true again).

(2) Thanks to the fact that you indicated that the problem could be with the HelveticaNeue font file(s), it occurred to me to check my font management app (Typeface). There I see that I have many varieties of the Helvetica family fonts activated and that could be creating a conflict.

(3) I disabled all the fonts that were enabled so that only the Mac system fonts were enabled.

Now the PayPal page is finally working! Thank you so much for guiding me to find the solution.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.