Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Messages Don't Bold Folders

  • 17 uphendule
  • 1 inale nkinga
  • 26 views
  • Igcine ukuphendulwa ngu RDWells

more options

To the point of nuking, then reinstalling accounts/groups in v91.1.2 (64-bit) from scratch, I still have the nitpicky problem of folders not going bold when new messages arrive.

I have restarted with add-ons disabled, but the problem persists.

I didn't have this problem with previous versions (with the same add-ons) until the latest two.

Any ideas, folks? TIA

All Replies (17)

more options

Are the folders set to get mail when the account is contacted? Right-click the folder, Properties, and see if 'When getting new messages...' is checked.

Helpful?

more options

The Inbox doesn't have that feature, but your suggestion DID serve to bold other folders which previously did not, so yours is a partial solution for which I thank you.

Helpful?

more options

Is the Inbox not indicating new messages? There has been an issue of Bitdefender's anti-spam component marking new messages as read, or there could be some other app that accesses messages before they reach TB.

Helpful?

more options

The inbox shows the number of new messages, is marked "Favorite" (by default?) and is not bold when new messages arrive. This is a new issue with TB's latest version(s) when everything else has not changed, at least of which I am not aware.

I have seen the issue with BitDefender addressed in other posts, but I do not use it, but wonder, since you mentioned it, if Microsoft Defender is messing with it somehow. I will turn it off for awhile and see what happens.

Helpful?

more options

I don't think Defender would do this, but just the same I would add the profile folder as an Exclusion in Defender settings.

I don't know why the Inbox would show the number of new messages but not be bold font. Maybe see if there's any difference in safe/troubleshoot mode (hold Shift when launching TB).

Helpful?

more options

Nope, I stated in the OP that Safe Mode with addons disabled had no effect.

Meh, I'll try it again, just to be sure.

Okulungisiwe ngu RDWells

Helpful?

more options

If you didn't want to test in a new profile, I think it's possible to force the folders to bold with a userChrome.css similar to the one here, if someone else doesn't provide a solution.

Helpful?

more options

I did mention in the OP that mine is a fresh install of v91.1.2, so there shouldn't be any corruption, in theory, of any kind.

Tried the userChrome.css suggestion but it didn't work; it removed boldface entirely from all folders/account names, at least my minimal understanding of how to use it, which I'm sure is nil. I will grant I very well might not have scripted it correctly.

What I have: - Accounts/groups in bold type - Folders remain in normal type when unread messages are present.

What I seek: - Accounts/groups in bold type - Folders with unread messages to be bold, esp., Inbox, which isn't happening at present, otherwise, normal typeface

I DID do the checkmark thing for "When getting new messages..." for other folders which DOES serve to bold them when unread messages come in (e.g., Spam/Junk/Bulk), so that's a start.

Helpful?

more options

The mozillazine topic is for making the font normal. Use font-weight: bold in the code, and toggle toolkit.legacyUserProfileCustomizations.stylesheets to true in Config. editor.

You did a fresh install of 91, but did you create a new profile or use the old one?

Helpful?

more options

Oop, yup, forgot to mention, yes, I did toggle that setting to true.

No, after reinstall, I recreated every account/group with a new profile.

Helpful?

more options

Do you have the accounts on any other devices? The fact that folders other than Inbox work as expected suggests there's something outside of TB affecting the Inbox.

Helpful?

more options

After nuking TB and once again recreating everything from scratch (new profile included), this time installing the latest v91.2.0, but no joy. Inboxes still remain unbolded upon arrival of new messages. This time, I even left off installing Phoenity icons, but that didn't matter.

This would lead me to concur with your assessment: it's not a TB thing, it's something peripheral. The burning question is, what the bleep is it?

No, I do not have accounts on other devices apart from a Yahoo email app on my phone but I can't imagine that would affect any account but one. None of the inboxes (ten total) go bold.

Helpful?

more options

If there's no third-party app on your computer that affects TB, look for some process at the mail provider end that is changing the read status. Run Windows in safe mode to bypass any startup app that might be interfering.

Helpful?

more options

Unfortunately, the problem is not account-specific; it happens with all accounts' inboxes.

I went back to your suggestion about using a userChrome.css file and FINALLY figured out where it goes, but even though you're on the right track, the coding doesn't quite perform the desired function. (Yes, I did toggle the config editor stylesheets setting to True.)

  1. folderTree > treechildren::-moz-tree-cell-text {
 font-weight: normal !important;

}

  1. folderTree > treechildren::-moz-tree-cell-text(hasUnreadMessages-true) {
   font-weight: bold !important;

}

...makes the tree (accounts/groups names) normal type (whereas I want them bold), folders within accounts/groups normal (desired), and didn't do squat about bolding an unread folder.

If I were to make the first section font-weight bold, then Accounts/Groups AND Folders become bold, not desired.

The other script section seemed to have no effect on outcome.

This is frustrating for something that should work out of the box as it has up until now.

Okulungisiwe ngu RDWells

Helpful?

more options

I still think it's something outside of TB, since it happens in a new profile. Windows safe mode is probably necessary to test this.

Helpful?

more options

Welp, I did that, but the problem persists. Good idea, but nope.

Helpful?

more options

Back now, with an update:

Bit the bullet and wiped/upgraded to Win 11, re-doing everything, including new installation of TB v91.2.0 (with new profile).

Folders still don't bold. I give up.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.