Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browser and Websites aren't displaying correctly.

  • 5 uphendule
  • 2 zinale nkinga
  • 20 views
  • Igcine ukuphendulwa ngu don47203

more options

Hello, John aka Beer Gutt here.

A while ago (about three months), I moved my hard drive to a new PC with better parts. It has a better mother board, a better graphics card and twice the RAM. Anyway, since then Firefox hasn't worked the same. When i open Firefox, there will be random pieces of letters or words on a webpage just gone, making a lot of them impossible to browse because I can't read half of the the new Alien dialect on the screen. Some websites have been better than others, but its gotten to the point where some web pages (Like YouTube or Reddit for example.) will just be a mess of random de fragmented lime green blocks that completely corrupt the page and will shift, move and appear at random covering up text as I scroll down. Videos will play just fine, it's the rest of the site that's effed up. Also on YouTube videos, where the timer for the video is located, some of the numbers just won't show up. Like it will count down fine but won't display certain numbers in the timer. Funny thing is, is that this doesn't just affect the websites, but the browser itself. For example, hovering my mouse over different tabs will highlight them and show me the preview text of the tab. All that is good until I move over to a different tab and voila, the text is gone, and then suddenly all the other tabs are either blank or just missing random letters and numbers in the tab. This is only happening in Firefox btw. No other app on my PC is doing this. I've tried refreshing Firefox about six times now, I've uninstalled it three times in an attempt to fix the issue along with restarting my PC multiple times... All of that, and I find out yesterday that it works perfectly when in "Troubleshoot/Safe mode", and only when in Troubleshoot/Safe mode. I have no idea what is causing the issue... *PePeLaugh* 
 See, I would use another browser but I've been using Mozilla for 8-9 years and would like to avoid the hassle of moving everything to a new browser... I would VERY much appreciate any help at all.
 I'm running 64-bit windows 8.1 on the latest updates and my PC specs are roughly as follows below. I look forward to a response...

MSi 970 Gaming Motherboard

AMD FX(tm) 8350 Eight-Core Processor 4.00 GHz

24 gigs of RAM

Asus Radeon R9 380 Graphics card

All Replies (5)

more options

Here's some screenshots i forgot to add...

Okulungisiwe ngu bumblebeergutt

Helpful?

more options

bumblebeergutt said

Hello, John aka Beer Gutt here. A while ago (about three months), I moved my hard drive to a new PC with better parts. It has a better mother board, a better graphics card and twice the RAM. Anyway, since then Firefox hasn't worked the same. When i open Firefox, there will be random pieces of letters or words on a webpage just gone, making a lot of them impossible to browse because I can't read half of the the new Alien dialect on the screen. Some websites have been better than others, but its gotten to the point where some web pages (Like YouTube or Reddit for example.) will just be a mess of random de fragmented lime green blocks that completely corrupt the page and will shift, move and appear at random covering up text as I scroll down. Videos will play just fine, it's the rest of the site that's effed up. Also on YouTube videos, where the timer for the video is located, some of the numbers just won't show up. Like it will count down fine but won't display certain numbers in the timer. Funny thing is, is that this doesn't just affect the websites, but the browser itself. For example, hovering my mouse over different tabs will highlight them and show me the preview text of the tab. All that is good until I move over to a different tab and voila, the text is gone, and then suddenly all the other tabs are either blank or just missing random letters and numbers in the tab. This is only happening in Firefox btw. No other app on my PC is doing this. I've tried refreshing Firefox about six times now, I've uninstalled it three times in an attempt to fix the issue along with restarting my PC multiple times... All of that, and I find out yesterday that it works perfectly when in "Troubleshoot/Safe mode", and only when in Troubleshoot/Safe mode. I have no idea what is causing the issue... *PePeLaugh* See, I would use another browser but I've been using Mozilla for 8-9 years and would like to avoid the hassle of moving everything to a new browser... I would VERY much appreciate any help at all. I'm running 64-bit windows 8.1 on the latest updates and my PC specs are roughly as follows below. I look forward to a response... MSi 970 Gaming Motherboard AMD FX(tm) 8350 Eight-Core Processor 4.00 GHz 24 gigs of RAM Asus Radeon R9 380 Graphics card

Helpful?

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Helpful?

more options

I already posted screenshots but here they are again...

Helpful?

more options

Yep, me too.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.