Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 92.0.1 (64-bit) for Windows does not work on www.t-mobile.com

  • 12 uphendule
  • 1 inale nkinga
  • 25 views
  • Igcine ukuphendulwa ngu hij2001

more options

I just moved to T-Mobile and when accessing this site, clicking on the login button takes several minutes to get to the login screen. After entering the username, it takes several more minutes to get to the password screen, after which it takes additional minutes for the following error message to be displayed.

             Looks like we got our wires crossed.
             We weren’t able to process your request at this time. Please try again later.

My Chrome and Edge browsers on Windows handle this site fine, as does Firefox on an M1 Mac running Big Sur, and safari on my iPhone - this is the only browser/OS setup that fails. I have cleared caches and cookies but nothing resolves this issue.

I would like to continue using Firefox but need to access this site. Any suggestions would be greatly appreciated!

Thanks and regards,

Howard

Isisombululo esikhethiwe

Fred -

Thanks for these suggestions! I am now able to log in to the t-mobile site. As I thought, the problem was not a corrupted profile, but creating a new profile allowed my to debug the issue from a known good configuration.

The new profile allowed me to successfully log into the site, after which I gradually started adding information and extensions from the original profile, verifying correct operation at each step. The last thing I did was update the default settings, and that uncovered the issue. When I selected "Enable HTTPS-Only Mode in all windows", the login process failed. Even though the t-mobile site is an https site as would be expected, their user id and password verification processes invoke a variety of scripts and additional websites. Apparently, one or more of the sites running these processes do not accept https. When accessing standalone http only sites with this mode selected, Firefox will display a dialogue to ask if you want to proceed with http, but if that message was created it was never visible, and those processes simply timed out causing the log in failure.

I have now reverted to my original profile, selected "Don’t enable HTTPS-Only Mode", and everything is working as it should. Thanks again for your timely responses and for continuing to provide new information. Have a great weekend!

Regards,

Howard

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (12)

more options

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Helpful?

more options

Fred -

Thanks for the prompt reply! Unfortunately, the behavior is exactly the same in safe mode, and McAfee is the only security software I'm running. There are no error messages other than the "... wires crossed... try again" I mentioned in my post. Flushing the caches and cookies was the first thing I tried, and as I said, the site works fine using Firefox on my Mac, as well as with Chrome and Edge on Windows and Safari on my iPhone. Really strange...

Helpful?

more options

Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

As a test, disable your protection programs.

Helpful?

more options

Fred -

Thanks again for more suggestions - all tried and still the same result. This is most puzzling since the site works fine with the other browsers on Windows and iOS, and with Firefox on Mac.

Regards,

Howard

Helpful?

more options

I called for more help.

Helpful?

more options

Excellent Fred - Thank You! Looks like you have additional insights into the support org that I don't have.

I just compared the settings on my Mac and Windows FireFox browsers (both at 92.0.1 (64-bit), and with the exception of a few that weren't relevant, they were identical. I changed some settings to make them consistent on both machines, and the MacAir still works and the Windows version does not.

Really curious...

Regards,

Howard

Helpful?

more options

Helpful?

more options

Isisombululo Esikhethiwe

Fred -

Thanks for these suggestions! I am now able to log in to the t-mobile site. As I thought, the problem was not a corrupted profile, but creating a new profile allowed my to debug the issue from a known good configuration.

The new profile allowed me to successfully log into the site, after which I gradually started adding information and extensions from the original profile, verifying correct operation at each step. The last thing I did was update the default settings, and that uncovered the issue. When I selected "Enable HTTPS-Only Mode in all windows", the login process failed. Even though the t-mobile site is an https site as would be expected, their user id and password verification processes invoke a variety of scripts and additional websites. Apparently, one or more of the sites running these processes do not accept https. When accessing standalone http only sites with this mode selected, Firefox will display a dialogue to ask if you want to proceed with http, but if that message was created it was never visible, and those processes simply timed out causing the log in failure.

I have now reverted to my original profile, selected "Don’t enable HTTPS-Only Mode", and everything is working as it should. Thanks again for your timely responses and for continuing to provide new information. Have a great weekend!

Regards,

Howard

Okulungisiwe ngu hij2001

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Helpful?

more options

Thanks Fred! I can't mark my own reply as "solved problem", but your post is now immediately under my original post as the "chosen solution", and anyone who needs more context can read through our thread.

Take care!

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.