Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox keep telling me to update every day, every time I log on?

  • 2 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu FredMcD

more options

Why does Firefox keep telling me to update every time I log on, and several times while I'm logged on? These messages are very annoying and unnecessary! I don't need your updates! I don't want any update that removes the "back" button! I like using the "back" button. I allowed Firefox to update a while back, and it removed the "back" button, so I had to do a big system restore to get the back button returned! Please stop sending the update messages! Firefox works fine without the stupid updates. Allow the "Back" button to be used. NO MORE UPDATES! The update messages are so annoying, I'm about to quit using Firefox.

All Replies (2)

more options

But we're not going to remove the Back button...

Helpful?

more options

How do you completely turn off update checks in Firefox v64? You can use a policies.json file to disable updates for all users. https://github.com/mozilla/policy-templates/blob/master/README.md or https://winaero.com/blog/disable-updates-firefox-63-above/

You can use a policies.json file in the distribution folder in the Firefox installation folder instead as also listed in the article, so no need to use GPO keys in the Windows Registry. • https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

You can use the ManualAppUpdateOnly policy in Firefox 87+ to enable only manual updates e.g. via "Help -> About Firefox".

Note that it is important to stay up to date and install the latest security patches.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.