Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

bookmarks line spacing doubled

  • 5 uphendule
  • 2 zinale nkinga
  • 27 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Hello, Since my last update, Firefox 93, my bookmarks present a huge line spacing between them, line spacing that I would like to control to see more bookmarks at a time. Do you know how to proceed ? Thank you very much.

Isisombululo esikhethiwe

To expand on the previous reply:

The optional Compact density setting tightens up the bookmark menus that drop from the main and bookmarks toolbar. Here's a comparison:

If you're interested in trying it (after you get Firefox 93), this article describes how to enable Compact Mode: Compact mode workaround in Firefox.

Note: That doesn't affect the classic menus that drop from the top bar (on MacOS, I think those are under system control), or right-click context menus.


Unofficial Community-Supported Workaround

Firefox users can modify the user interface of the browser using custom style rules. This involves setting up a userChrome.css file. If this is your first time, make sure to set aside 10 quiet minutes to work through it.

The full instructions are in the following reply: https://support.mozilla.org/en-US/questions/1346577#answer-1435049

DISCLAIMER: modifications made through a userChrome.css file often stop working as Firefox evolves in new releases, and occasionally "breaks" the interface in serious ways. You can (re)start Firefox in its Troubleshoot Mode to bypass the userChrome.css file so you can get Firefox running, and then edit or remove the file as needed.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

In Firefox 93, I understood it would be possible to do that by selecting compact mode density. If you don't already have that option in Customise Toolbar, you can get it by making the following preference true in about:config. browser.compactmode.show

If that doesn't suffice, you can use a file called userChrome.css to tighten the spacing. You can probably find links to code on the reddit sub FirefoxCSS.

Helpful?

more options

Isisombululo Esikhethiwe

To expand on the previous reply:

The optional Compact density setting tightens up the bookmark menus that drop from the main and bookmarks toolbar. Here's a comparison:

If you're interested in trying it (after you get Firefox 93), this article describes how to enable Compact Mode: Compact mode workaround in Firefox.

Note: That doesn't affect the classic menus that drop from the top bar (on MacOS, I think those are under system control), or right-click context menus.


Unofficial Community-Supported Workaround

Firefox users can modify the user interface of the browser using custom style rules. This involves setting up a userChrome.css file. If this is your first time, make sure to set aside 10 quiet minutes to work through it.

The full instructions are in the following reply: https://support.mozilla.org/en-US/questions/1346577#answer-1435049

DISCLAIMER: modifications made through a userChrome.css file often stop working as Firefox evolves in new releases, and occasionally "breaks" the interface in serious ways. You can (re)start Firefox in its Troubleshoot Mode to bypass the userChrome.css file so you can get Firefox running, and then edit or remove the file as needed.

Helpful?

more options

i have tried all 3 methods posted here to get less vertical spacing between my bookmarks. Are there any other ways? I have tried these 3 1) More tools/Customize toolbar. Then Density at the bottom. Clicked on Compact NOT supported.

2) about:config.  Found browser.compactmode.show . Switched toggle to TRUE

3) created a css file to Profiles

Helpful?

more options

Your screenshot shows drop down list in the Bookmarks menu on the menu bar. Compact mode only works for folders on the Bookmarks Toolbar and not for the main menu bar. For the main menu bar you need to use code in userChrome.css and enable this file via about:config.

Helpful?

more options

If you generally interact with your Bookmarks menu using the mouse, another option is to move the optional Bookmarks Menu button to the Menu Bar (it has to go at one end or other other, it can't go in the middle), since that one has a list which can be compacted.

To do that, drag the button up to the bar and drop it there using the Customize panel (Customize Firefox controls, buttons and toolbars).

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.