Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Socks5 proxy doesn't work well with network.trr.mode = 3 and network.proxy.socks_remote_dns = false on Fx 92.0!

  • Akukho zimpendulo
  • 1 inale nkinga
  • 18 views
more options

After upgrade to Fx 92.0, my ISP ip is shown as IP address when I visit ip.voidsec.com after every startup of Firefox! The socks5 proxy would work properly only after that page been refreshed several times. But if I change the value of network.trr.mode frome 3 to 2 or the value of network.proxy.socks_remote_dns from false to true, the socks5 proxy would work properly at once. It used to work well all the time on Firefox 91.0!

PS:Fx 90.0 also skips socks5 proxy sometimes while Fx 89.0 doesn't with the same settings. It can be easily reproduced. I think it's a bug.

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.