Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

since its latest damn update firefox requires i give permission to go to my own home page!!!

more options

Since its latest update, I think, not sure which one as it has so very many, all causing me problems; firefox now no longer takes me to my homepage even tho that is the one I have chosen in my ff settings. It is the page that came on everytime I go online or open another window. It is my main email account and I go on it for many reasons through out the day. But now instead of taking me to my homepage it puts up a stupid message telling me the page doesn't need authentication and could be a trick, do I still want to go on it. As I am always working and going on this page this has become a big time waster and aggravation. I have tried several things, can't fix it. How do I get rid of this stupid message. My homepage has been the same for years.

All Replies (10)

more options

shonatrill said

But now instead of taking me to my homepage it puts up a stupid message telling me the page doesn't need authentication and could be a trick, do I still want to go on it.

Is that a phishing warning (red page) or something else? (How does built-in Phishing and Malware Protection work?)

Do you think it could be because the page has an HTTP address instead of an HTTPS address, or is the address in the Custom URLs box on the Settings page an HTTPS address?

If you haven't updated this home page address for a long time, you might update it with the latest address in case the old address needs to redirect and that is making Firefox suspicious. More info: How to set the home page.

more options

The address for the homepage is the same as my email address and has been the same for many years. It is my main email. I did change it and then changed it back to the same as always to see if that would do anything, but nothing changed and it still sends that msg. constantly everytime I go to a new window, online , etc. I will look at the 'how to make your homepage link you sent. Thanks for your input. I am angry because I have so much to do and this message from fox comes constantly.

more options

I found more information about this warning, which apparently has been in Firefox for a long time.

Sometimes you may follow an address with this format

https://username:password@example.com/

What Firefox is saying is that the site example.com does not use an old-school basic authentication prompt, so it is a suspicious that you are sending text that follows the username:password convention at the start of the URL. According to a Firefox source code file, "this warning is intended to protect the user against spoofing attempts that use the userpass field of the URL to obscure the actual origin server." For example, let's say you clicked this URL:

https://www.google.com:1234567890@example.com/

Firefox asks whether you want to go to example.com in case you thought that was a link on www.google.com:

So what to do? Two options:

(1) Remove the part after // and up to and including @

In the old days, users might include their credentials in the URL to preload a login form with the username and password. However, if you don't need to send that part, it is recommended not to do that.

(2) Create a preference to bypass the warning (Not recommended)

If you don't want this protection, you can bypass it this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste network.http.phishy-userpass-length and pause while the list is filtered

(3) On the line with network.http.phishy-userpass-length and the options Boolean Number String, click the button in front of number and click the "+" button

(4) Firefox should open up an editing field to enter a number -- this is the length of the username:password section that you want Firefox to ignore -- in other words, Firefox would only warn you if the username:password section was longer than this. You could enter a value like 20 then press Enter or click the blue check mark button to save the change.

More info on about:config: Configuration Editor for Firefox.

Edit: Image added

Okulungisiwe ngu jscher2000 - Support Volunteer

more options

You said in your post that this message has been in ff a long time. I have used only ff for over a decade and I never saw it before the last update and I have used the same home page for years. It is a new and time wasting thing. I am a senior and wasn't raised with computers. I appreciate your help but I didn't understand a thing you were trying to tell me. Sorry. I just want to get rid of the message. I use my email as my home page. It is a standard email blank@gmail.com. That's all I have ever used for years and years and never had a problem.

Okulungisiwe ngu shonatrill

more options

In your post you said that the message has been in ff for years. I have used only ff for over a decade, and have had the same homepage address for many years. I never saw the message until about 4 days ago I guess. My homepage is the same as my email address. It is in this form: blank@gmail.com. That's it. I am a senior and not very computer literate. I appreciate your efforts to help me, but I don't understand a thing in your post. I'm sorry. I just want this stupid msg. gone and have no idea as to why its suddenly appeared. I have to deal with it constantly. Does ff have any technical support at all? Here is the message: " You are about to log in to the site “gmail.com” with the username "blank", but the website does not require authentication. This may be an attempt to trick you. Is “gmail.com” the site you want to visit?" Then I have to click 'yes or no' at the bottom of the msg. As I said have never seen this till the last update.

Okulungisiwe ngu shonatrill

more options

I have tried to reply twice and when I click update reply after editing the message disappears. I will try tomorrow . But the message I get has not been in ff a long time. I have used ff for over a decade, and had the same homepage address for years. Never saw that msg till the last update. Sorry but I am a senior, not raised with computers and did not understand anything in your last post. I appreciate you're trying to help me. Doesn't ff have any tech support that can fix this? Late for me here. Where do my msg. go when I click 'update my answers? For an immense co. like ff this is really weak.

more options

Sorry, I think your replies were hidden because they contained a link.

Try changing your home page address to this:

https://mail.google.com/mail/

more options

Hi Jscher2000 I did change my homepage as per your previous suggestion, to an https yesterday; not exactly like the one you are suggesting, I took it from the address bar when I signed in to my email, and that does seem to solve it. I am saving the address you provided above in case there are more problems. Thank you for taking all this time and trouble to help me, and others . Have a great day!

more options

Jscher2000, I wanted to add something to my above comment, but 'edit' seems to have disappeared. So am adding this comment. While my problem has been hopefully, solved, it should be of concern to ff as to why it suddenly occurred in the first place. I had not changed anything in my settings, homepage, email address, so on; prior to the update. I had all of those the same for many years. Suddenly this time wasting message appeared everytime I went online, opened a window, so on; interfering with my work. It's not enough to solve it, ff should determine why it happened in the first place. Another thing is that my ff worked fine before any of the now more frequent updates. Each time now when they update I have to go in and spend a day getting things back up. The updates don't do a damned thing for me and people I know and the program already has too many bells and whistles, like gmail with all its labels and other stupid things no one wants. I avoid the updates as long as possible and wonder at the mindset of all the people running tech companies that they can't leave a good thing alone. They should look at the big change CocaCola made to their product back in the last century, which they had to rescind as it almost destroyed the company. As well it is amazing that probably the most used browser in the world had no technical support. To me that is negligent. I am going to be trying other browsers as am tired of having to fix the problems the seemingly weekly updates cause. I hope this gets passed to management. And thank goodness for volunteers like you, but they should be paying you.

more options

shonatrill said

Each time now when they update I have to go in and spend a day getting things back up.

That's not normal, especially with minor updates like 91.0.1 and 91.0.2 which fix a couple small things.

You are not the only person whose Firefox is disrupted by updates, but I haven't seen enough information on these cases to know what is going wrong. That makes it difficult to suggest workarounds or to file an actionable bug report.