Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Persistent Pop-up

  • 7 uphendule
  • 1 inale nkinga
  • 35 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hello,

Every time I log in to Outlook.com in Firefox a pop-up automatically appears below the address bar. The persistent pop-up: Add "outlook.live.com" as an application for mailto links? See screenshot attached.

Troubleshooting and modifying Settings to eliminate pop-ups and recommendations didn't stop the pop-up. Deleting Firefox beta and installing the standard version of Firefox didn't work either. The only way to manage this pop-up is to click on the "X" button to close it each time I open or refresh my Outlook.com home page. Then I get some screen space back.

Using Edge, the pop-up includes other options to choose from such as "Don't show this again", which I selected. I don't see the pop-up any more in Edge.

Why can't I get rid of this unwanted, persistent, recommendation pop-up in Firefox?

Thanks, Gordon

Ama-screenshot ananyekiwe

All Replies (7)

more options

Edge is a Microsoft program. The web page and the pop-up are Microsoft. Firefox is not.

Some adblockers can be set to block elements of a web page like that ad.

Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for a good ad blocker.

Helpful?

more options

8/22/21 AdBlockPlus will not block the element that says "Add "outlook.live.com" as an application for mailto links?"

Helpful?

more options

Check with AdBlockPlus support.

Helpful?

more options

Ozarkslandscaper is correct, Adblock Plus does not work. You can’t click on the pop-up because it is outside the top boundary of the work area. That is, the Adblok Plus area of operations does not include the header area where the pop-up is located.

According to Microsoft, the root cause of the problem lies within Firefox. For insight on the origin of the problem visit https://answers.microsoft.com/en-us/o.../9a891915-bde2-47dc-8de4-9bfd275c4ecd

I clicked on the “Add application” button in the pop-up just to see what happened. Then I went to Settings > General and scrolled to Applications. There, I clicked on "mailto" and in the dropdown list was “Use outlook.live.com”. One can select it for their webmail or ignore it. The upside, the pop-up no longer populates the Outlook.com home page each time you open it or refresh the page.

Not the Firefox solution I was expecting.

Gordon

Helpful?

more options

That notification bar is part of the Firefox user interface, so you would need code in userChrome.css to be able to hide it.

See also:

Helpful?

more options

Does this mean that nobody at Mozilla Support is aware of the problem and trying to fix it for the next update?

Helpful?

more options

If you accept this and add Outlook to the mailto choices in "Settings -> General -> Applications" then you will no longer see this notification bar.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.