Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Where are the security settings for the editor?

  • 5 uphendule
  • 1 inale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu jscher2000

more options

After years of being able to copy and paste directly in FF, it seems that I'm unable to do so now. Now I have to right-click, select Paste and then Ctrl+V into the box. This is the message at the top of the box:

Because of your browser security settings, the editor is not able to access your clipboard data directly. You are required to paste it again in this window. This really slows me down.

Ama-screenshot ananyekiwe

All Replies (5)

more options

This article doesn't appear to be applicable, as user.js doesn't seem to exist, nor the extension. The article also doesn't explain how to enter the suggested lines in about:config

http://kb.mozillazine.org/Granting_JavaScript_access_to_the_clipboard

Helpful?

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Helpful?

more options

The issue still appears to be there.

That said, in normal mode, if I e.g. copy your answer, select this reply box and press Ctrl+V, the copied text gets pasted. If I try the same in another forum, it doesn't and I've to right-click, select Paste and I then get that dialog box as in my original post. It does work if I copy from an external source, e.g. a text editor.

Helpful?

more options

Upon further investigation, I discovered that the forum in question uses CKEditor. So it might be CKEditor's internal configuration which is the cause.

Helpful?

more options

It could be CKEditor if it's a very old or very new version.

Another thing to check is the following preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste dom.event.clipboardevents.enabled and pause while the list is filtered

(3) If the has a value of false, double-click it to restore the default value of true

More info on about:config: Configuration Editor for Firefox.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.