Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

YouTube videos take a long time to load!

  • 9 uphendule
  • 1 inale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Hello, as described in the topic, YouTube videos always take 15-20 seconds (sometimes longer) to start. It's not because of my internet because with Chrome and Edge they start immediately. I also cleaned up Firefox and then it ran 1 day better and then worse again. What can I do now to fix this problem?

Thank you!

All Replies (9)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Hello FredMcD,

when i switch in the Troubleshoot Mode the Problem is much better. But i cant use my Ad Ons there. That means that a Add One cause this Problem?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

Hello FredMcD,

i try it like you describe above but after deactivating one after another the Problem exists. I also have turn HW Acceleration off but with no Luck. Toolbars and Anti Virus Add Ons i didnt use. I installed Chrome with all the Extensions and there i have no Problems. The Videos play very Quick.

What can i do more please?

more options
more options

Hello FredMcD, i have made it like you describe. When i first open FF after loading up with the new profile YT worked without problems. It loads quick like in Chrome. When i close FF and start it again and start YT there are the long loading times again :(

Okulungisiwe ngu leckmirdiepoperze

more options

Do you mean with the new profile or the old one?

Do this for YouTube;

Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

more options

FredMcD said

Do you mean with the new profile or the old one?

With the new Profile.

I made this like you write above and there is the same Problem after i close FF 2-3 Times and start it. After the First Start after i make the things you write all is ok but when i close FF few Times and Start it the Poblem with the YT Videos begin.

Okulungisiwe ngu leckmirdiepoperze

more options

I called for more help.