Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Menu drop down items not visible

  • 2 uphendule
  • 1 inale nkinga
  • 27 views
  • Igcine ukuphendulwa ngu cor-el

more options

In the menu drop downs under 'Edit' and 'View' and 'History' there are items that are 'inactive' and cannot be selected.

I have changed the background colour and look of the Menu drop downs in my CSS file but am looking for a way to show the 'unselectable' items.

In the Edit menu it is: Redo , Cut, Copy, Delete and associated keyboard shortcuts that have black text. i need light grey.

In the View menu it is: Text Encoding that is black

In the History menu it is: Recently closed windows

Does anyone have the code required to make them look light grey even if not 'selectable'. I have all selectable items with white text as the drop down background colour is teal.

I would appreciate any help I can get.

Haagen

In the menu drop downs under 'Edit' and 'View' and 'History' there are items that are 'inactive' and cannot be selected. I have changed the background colour and look of the Menu drop downs in my CSS file but am looking for a way to show the 'unselectable' items. In the Edit menu it is: Redo , Cut, Copy, Delete and associated keyboard shortcuts that have black text. i need light grey. In the View menu it is: Text Encoding that is black In the History menu it is: Recently closed windows Does anyone have the code required to make them look light grey even if not 'selectable'. I have all selectable items with white text as the drop down background colour is teal. I would appreciate any help I can get. Haagen

Isisombululo esikhethiwe

That is this CSS rule in chrome://global/skin/menu.css => color: GrayText;

You can override this color with a color of your choice in userChrome.css with the "!important;" flag appended.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

menu[disabled="true"],
menuitem[disabled="true"],
menucaption[disabled="true"] {
  color: GrayText !important; /*your preferred color*/
}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

more options

Isisombululo Esikhethiwe

That is this CSS rule in chrome://global/skin/menu.css => color: GrayText;

You can override this color with a color of your choice in userChrome.css with the "!important;" flag appended.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

menu[disabled="true"],
menuitem[disabled="true"],
menucaption[disabled="true"] {
  color: GrayText !important; /*your preferred color*/
}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true