Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 90 does not load properly specific web pages and services (gmail, youtube, reCAPTCHA, etc.)

  • 3 uphendule
  • 1 inale nkinga
  • 16 views
  • Igcine ukuphendulwa ngu imkere

more options

Two weeks ago my browser updated itself to version 90. Before that everything was OK.

After that..... Firts of all in Google Chrome everything works just fine. In Firefox - most of the time after a google search if I click on one of the results nothing happens. If I open it in a new tab or window, I got a blank page. - I cannot log into my gmail account. I can get to the page where I can type in my account name, but then I get an error message before the web page'd ask for my psw. - youtube does not load properly. If then I click on the youtube icon on the top left corner then it tries to load the page again, and after some time it says I have no internet connection. - google translate service does not answer, - reCAPTCHAs don't work. The browser could not load them, or if it loads something then it won't work. Etc.

Again: everyhing was OK before the version 90 update. I was on a 2 weeks vacation, just got back, but all the same, they don't work.

I tried everything - cleared the history, cache, etc., - checking the firewall, - proxy (I don't use any proxy), - ipv6 - made a new profile - troubleshooting mode (disabeling addons and themes), everything. Nothing helped.

I use Win10. Have an other Win10 PC, on that before the version 90 update I checked the problems above, and neither of them affected the system, and as the update taked place I got the same propblems there too. My firefox profile is synched onto that PC.

After 20+ years of using firefox this is my last try before switching to chrome.

Ama-screenshot ananyekiwe

Okulungisiwe ngu imkere

Isisombululo esikhethiwe

Just updated my firefox to v91, which solved the problems above. So there was something in v90 causing those issues.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Helpful?

more options

cor-el said

You can check the connection settings.
  • Settings -> General -> Network: Connection -> Settings
If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings":

Thanks for your answer!

I've already tried everything on that page (proxy, ipv6, dns, etc.). Tried to start the browser in troubleshoot mode, tried to make a new profile too, but the problem does not vanished. As I can see my problem somehow related to google services (gmail, youtube, google search, google translate). And reCAPTCHA. To be onest I don't use facebook, twitter, other social media, so I don't know what about that sites.


And some web pages sometimes don't or just slowly load the pictures. But if I refresh the page the pictures appear immediately.

As I said before, this problem has occurred right after the version 90 update. Before that everything was fine.

Only one thing I have not tried yet is to completly reintstall the firefox. But this problem had to be related to my profile, because as my other PC, where the firefox is synched to my main PC, updated to version 90 too, the problem appeared right after the update (I checked it before and after the update). So I don't know if a complete reinstall would be help me out or not, the problem somehow is in my firefox profile.

Okulungisiwe ngu imkere

Helpful?

more options

Isisombululo Esikhethiwe

Just updated my firefox to v91, which solved the problems above. So there was something in v90 causing those issues.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.