Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Symbols not displayed correctly

  • 6 uphendule
  • 1 inale nkinga
  • 396 views
  • Igcine ukuphendulwa ngu holzweg

more options

When I open a website using special symbols, the symbols are replaced by a sign with 6 hex symbols in it.

It even happens when the symbol is used in the page title (see image). Site used: https://emojipedia.org/yawning-face/).

Interestingly, other emojis from the same site are displayed correctly (means the '01F971'-type symbol is replaced by the emoji, in all occurrences on the site and title)

I have seen multiple threads about this, even on this site. However, I could not solve it with the suggested solutions. What I have tried so far:

1. Disable addons 2. Make sure fonts are downloaded through settings 3. about:config -> gfx.downloadable_fonts.enabled -> make sure its true (4. no-script is not installed)


Any ideas?

When I open a website using special symbols, the symbols are replaced by a sign with 6 hex symbols in it. It even happens when the symbol is used in the page title (see image). Site used: https://emojipedia.org/yawning-face/). Interestingly, other emojis from the same site are displayed correctly (means the '01F971'-type symbol is replaced by the emoji, in all occurrences on the site and title) I have seen multiple threads about this, even on this site. However, I could not solve it with the suggested solutions. What I have tried so far: 1. Disable addons 2. Make sure fonts are downloaded through settings 3. about:config -> gfx.downloadable_fonts.enabled -> make sure its true (4. no-script is not installed) Any ideas?
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

@FredMcD: It solved my problem (for this example at least), even when going back to normal mode. Maybe it was just about restarting the application. See below.


@jscher2000: It says: Apple Color Emoji. In the meantime I downloaded a newer .ttc file and installed it.

@cor-el: I am on 10.14. So this adds to my impression that it was about the Emojis on MacOS not updating without OS update (similar to iOS).

Dear all, thank you for supporting me and excuse me, as it doesnt seem like firefox was the source of this problem.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

more options

Thank you, but this is what I already verified under #2, as I saw it in former threads about this problem.

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

more options

If you take a look here --

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste font.name-list.emoji and pause while the list is filtered

-- what fonts are listed? (On Windows, we have "Segoe UI Emoji, Twemoji Mozilla"; I'm sure Mac has its own Emoji font.)

The ones your Firefox is using may not be working if you can't see emojis.

If the preference is bolded, indicating that it has been customized, there should be a reset button at the right end of the row (an arrow that arches leftwards). You could try clicking the restore the default list.

more options

On Mac this would be "Apple Color Emoji"

Make sure you have the latest version of this font installed to have support for emojis added during the last years. It is also possible that OS X 10.14 doesn't support those emojis (i.e. you may need 10.15 Catalina).

more options

Isisombululo Esikhethiwe

@FredMcD: It solved my problem (for this example at least), even when going back to normal mode. Maybe it was just about restarting the application. See below.


@jscher2000: It says: Apple Color Emoji. In the meantime I downloaded a newer .ttc file and installed it.

@cor-el: I am on 10.14. So this adds to my impression that it was about the Emojis on MacOS not updating without OS update (similar to iOS).

Dear all, thank you for supporting me and excuse me, as it doesnt seem like firefox was the source of this problem.