Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No text showing, only images from today on one news website.

  • 14 uphendule
  • 1 inale nkinga
  • 22 views
  • Igcine ukuphendulwa ngu kryten

more options

I haven't installed any new Add-ons for over a year but suddenly today the Telegraph.co.uk website is only displaying images. I disabled all Add-ons, re started FF but that hasn't fixed it. Safari is okay though. Mac 10.11.6 and FF 78.10.1esr Thanks for any tips, can't do without a proper newspaper. Kryters.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Apologies for late response. I have bought a new iMac and FF works perfectly on the troublesome site. But we'll never know what the problem was, so sorry about that. I'm not as familiar with FF as some of the experts on here but sincere thanks to all for the responses.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (14)

more options

Does the text appear if you try to select text e.g. via Select All in the right-click context menu ?

This can also be a problem with the font that is used on this webpage.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

If you use uBlock Origin make sure not to "block remote fonts".


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

more options

Thanks for that cor-el. I'm not familiar with the Inspector but none of the above seemed to work. The text is there as you can see in the screengrab.

Helpful?

more options

As an update to this, the same problem now exists with my HP laser printer at 192.168.1.16. No text, just the menu headings. Okay in Safari though. It seems that everytime an update comes out it breaks something else. Kind of frustrating.

Helpful?

more options

Can you paste an url for the site you are using? Paste the full url, don't use the paperclip icon.

Helpful?

more options

Yes, thank you Terry - https://www.telegraph.co.uk/ EDIT: I forgot to mention that initially the text displays for around 1 second, then disappears.

Okulungisiwe ngu kryten

Helpful?

more options

Did you try Firefox Troubleshoot Mode as this might be caused by an extension ?

Helpful?

more options

Yes, I've tried that, Option + Launch but it doesn't work. I still get no text, weird.

Helpful?

more options

If it works for a short time then this would suggest that downloading a font from the server via an @font-face rule for some reason or Firefox isn't able to use this font.

Any font related errors or warnings in the Web Console?

Helpful?

more options

I am not getting the error. Text displays and stays. Enhanced Tracking Protection is on.

Helpful?

more options

Sorry I'm no expert with FF but does the attached tell us anything?

Helpful?

more options

Helpful?

more options

Thanks Terry. When I get a bit of time, I'll take a look at this. The troublesome site works on every other machine in the office on several OS's inc PC's but not this old Mac. Has worked for years but not now.

Helpful?

more options

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

more options

Isisombululo Esikhethiwe

Apologies for late response. I have bought a new iMac and FF works perfectly on the troublesome site. But we'll never know what the problem was, so sorry about that. I'm not as familiar with FF as some of the experts on here but sincere thanks to all for the responses.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.