Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prime Video: "Your browser does not support High-Definition playback due to content restrictions"

  • 6 uphendule
  • 1 inale nkinga
  • 61 views
  • Igcine ukuphendulwa ngu jrh

more options

Since 88.0.1 all Amazon Prime Video content displays this message: "Your browser does not support High-Definition playback due to content restrictions. Please update your browser for the best Prime Video experience".

I've tried turning off vpn, adblocker, and set tracking protection back to 'standard', nothing helps.

I'm on W10 1909 Home which is technically not supported by MS as from this week so I did consider that as a possible (but unlikely) reason for it. However, the content plays fine in MS Edge. The content also plays fine from a laptop running Chrome on 1909 Enterprise (similar build to mine albeit not out of support yet).

I see widevine was updated in 88.0.1 - could this be the issue?

Thanks

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Resolved. I was about the reinstall and then considered clearing all cookies and data.

Once that was done, content is playing correctly again.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Is it really 88.0.1? It should be fixed in this version.

Helpful?

more options

Yes. I didn't have any issues with 88.0 - content played fine for me.

The bug report for 88.0 seemed to be for bought Amazon content, which I don't have. Maybe the bought stuff is handled slightly differently to the included with Prime stuff that I'm trying to watch.

Helpful?

more options

I can confirm it has nothing to do with 1909 as I've updated to 20H2 and the problem is still there.

Anyway to rollback to a functioning version of Firefox?

Helpful?

more options

What Widevine version are you using (about:addons -> Plugins) ?

Helpful?

more options

It's 4.10.2209.1

Helpful?

more options

Isisombululo Esikhethiwe

Resolved. I was about the reinstall and then considered clearing all cookies and data.

Once that was done, content is playing correctly again.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.