Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't load on Macbook M1 using Guest User

  • Akukho zimpendulo
  • 1 inale nkinga
  • 2 views
more options

We use the Guest User to login to checked out iPads to students. We are using Macbook Airs with the M1 chip. When trying to use Firefox I received the error message "you don't have permission to open the application". I received this message for Google also. So I uninstalled both apps under my admin login and reinstalled with the latest versions. I also updated the MB Air to the latest Big Sur version. Google was able to load without a problem. Firefox on the other hand will not load. It bounces once in the dock and then doesn't continue to load. I logged back in with my Admin user and changed the permissions to see if that worked and Firefox still won't load. So I tried to lower the Security setting for the MB Air and that also did not work for Firefox.

Any suggestions on what else to try?

Thanks in advance.

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.