Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Block audio and video setting not working, videos still autoplay

  • 2 uphendule
  • 1 inale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu ka.kirk818

more options

I've used Firefox for many years, and NEVER has the "block audio and video" setting ever worked. It is really annoying to be trying to read an article and have a video playing - distracting me - while I'm trying to read. When I try to ignore it and scroll past, it pops out and starts playing in the lower right hand corner in the way of whatever I'm trying to read, so I have to close the video down. I'm not a programmer, I'm a simple user. Why is Mozilla even pretending to block videos when they don't?

All Replies (2)

more options

You can look at these prefs on the the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Helpful?

more options

As I stated previously, I am not a programmer and I am not comfortable messing around in the workings. All I want is for Mozilla to make the feature that supposedly blocks autoplay to actually block autoplay.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.