Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to open Firefox on Big Sur

  • 2 uphendule
  • 1 inale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu Ken Creary

more options

Firefox fails to load with the following details:

Process: firefox [26134] Path: /Applications/Firefox.app/Contents/MacOS/firefox Identifier: org.mozilla.firefox Version: 88.0 (8821.4.15) Code Type: X86-64 (Native) Parent Process:  ??? [1] Responsible: firefox [26134] User ID: 501

Date/Time: 2021-04-30 07:09:53.948 -0400 OS Version: macOS 11.2.3 (20D91) Report Version: 12 Anonymous UUID: 28F22F8D-3DA5-6790-CE30-0EA497DB9F8E

Sleep/Wake UUID: 275B7F58-1F53-4F13-B662-AC22B471CDC1

Time Awake Since Boot: 480000 seconds Time Since Wake: 2600 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT) Exception Codes: 0x0000000000000000, 0x0000000000000000 Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information: dyld: launch, loading dependent libraries

Dyld Error Message:

 dyld: Using shared cache: 52762DF1-0E55-3F8B-9588-8169E6D0EB95

Library not loaded: @executable_path/libmozglue.dylib

 Referenced from: /Applications/Firefox.app/Contents/MacOS/firefox
 Reason: no suitable image found.  Did find:

/Applications/Firefox.app/Contents/MacOS/libmozglue.dylib: open() failed with errno=1 /Applications/Firefox.app/Contents/MacOS/libmozglue.dylib: open() failed with errno=1 /Applications/Firefox.app/Contents/MacOS/libmozglue.dylib: stat() failed with errno=1

Binary Images:

      0x1019f7000 -        0x1019f9fff +org.mozilla.firefox (88.0 - 8821.4.15) <72B39733-5449-3E84-9543-19F83BF995E0> /Applications/Firefox.app/Contents/MacOS/firefox
      0x1030bc000 -        0x103157fff  dyld (832.7.3) <0D4EA85F-7E30-338B-9215-314A5A5539B6> /usr/lib/dyld
   0x7fff202f3000 -     0x7fff2032bfff  libobjc.A.dylib (818.2) <EB6B543F-D42C-3FB2-A2EC-43407C5F80D3> /usr/lib/libobjc.A.dylib
   0x7fff2cce5000 -     0x7fff2ce15fff  com.apple.audio.toolbox.AudioToolbox (1.14 - 1.14) <8E53C25F-9FE2-372E-8374-6A598D72C4C1> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
   0x7fff350e8000 -     0x7fff350ebfff  com.apple.Cocoa (6.11 - 23) <B0F6AF8E-B85C-3C5C-9812-9CD8BC07ADB2> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
   0x7fff3c619000 -     0x7fff3c61cfff  com.apple.ExceptionHandling (1.5 - 14) <30D9F433-5B2B-3B3F-9822-C150CDEA23E2> /System/Library/Frameworks/ExceptionHandling.framework/Versions/A/ExceptionHandling

Model: iMac18,2, BootROM 429.80.1.0.0, 4 processors, Quad-Core Intel Core i7, 3.6 GHz, 16 GB, SMC 2.40f1 Graphics: kHW_AMDRadeonPro560Item, Radeon Pro 560, spdisplays_pcie_device, 4 GB Memory Module: BANK 0/DIMM0, 8 GB, DDR4 SO-DIMM, 2400 MHz, 0x80AD, 0x484D413831475336414652384E2D554820202020 Memory Module: BANK 1/DIMM0, 8 GB, DDR4 SO-DIMM, 2400 MHz, 0x80AD, 0x484D413831475336414652384E2D554820202020 AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x16E), Broadcom BCM43xx 1.0 (7.77.111.1 AirPortDriverBrcmNIC-1675.1) Bluetooth: Version 8.0.3d9, 3 services, 27 devices, 1 incoming serial ports Network Service: Ethernet, Ethernet, en0 Network Service: Wi-Fi, AirPort, en1 Serial ATA Device: APPLE HDD HTS541010A9E632, 1 TB USB Device: USB 3.0 Bus USB Device: Bluetooth USB Host Controller USB Device: FaceTime HD Camera (Built-in) USB Device: Apple USB SuperDrive USB Device: USB 2.0 Hub [MTT] USB Device: HD Pro Webcam C920 USB Device: My Book 25EE USB Device: Cyborg R.A.T.9 Wireless Mouse USB Device: USB to ATA/ATAPI bridge Thunderbolt Bus: iMac, Apple Inc., 41.4

Ama-screenshot ananyekiwe

All Replies (2)

more options

"org.mozilla.firefox (88.0 - 8821.4.15)"

try rolling back/downgrading to the previous FF version.

i think version 78 seems to be stable for most mac users.

Helpful?

more options

I don't think that will fix it. I have the same version running fine on another device on the same OS. Something on this machine is keeping the library from getting loaded. I'll keep searching...

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.