Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

constant updates disrupt settings

  • 4 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu Scribe

more options

hi, i'm mostly interested in getting some help with creating my settings/preferences to stay the way i want them. every time there's a update, my personal settings get wiped out and i have to start all over again. there was a time when FF offered a way to leave some updates out and select the ones we wanted. now, it's all blanket updates. many times i lose important tabs and files. it's annoying. the way these updates are coming in i cringe each time i see the notice. and then there are times they get done automatically.

what's a mother to do?

many thanks for your consideration!

All Replies (4)

more options

Hi, you can prevent automatic installation of updates and only do it when you are ready as follows: Open the 3-bar menu > Preferences/Options > (General) > Firefox Updates, and set it to 'Check for updates but let you choose to install them.' Also deselect 'Use a background service to install updates.'

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

more options

yes, i've got that set; although i STILL get the reminder pop-up, sometimes several times a day. is there a way to stop that pop-up?

Helpful?

more options

This article may help: https://support.mozilla.org/en-US/kb/recover-user-data-missing-after-firefox-update If your system has a package manager, I would use that to update rather than update direct from Mozilla. I never have your issue after updating as far as about:preferences is concerned. Mozilla is forever messing with about:config.

Helpful?

more options

If you just want to restrict the number of update notifications, you can try this, which should reduce it to no more than once a day. Type about:config into the address bar, press Enter/Return and accept any warning, then copy and paste the following into the search box app.update.checkInstallTime Now on the search result, click the Toggle button at the right-hand end to change from True to False, then restart Firefox.

It is possible to stop all notifications and still allow you to update manually, but it's a bit technical and only works from Firefox 87: See Customizing Firefox Using policies.json and https://github.com/mozilla/policy-templates/blob/master/README.md#manualappupdateonly You would need to use the ManualAppUpdateOnly policy. See the top of the article for further instructions.

Okulungisiwe ngu Scribe

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.