Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to keep the sidebar on bookmarks

  • 4 uphendule
  • 1 inale nkinga
  • 193 views
  • Igcine ukuphendulwa ngu cor-el

more options

The sidebar that is brought up by clicking on the sidebar button normally shows whatever you choose on its dropdown menu (Bookmarks, History, or synced tabs). And it used to be, if you choose Bookmarks on that menu, it shows bookmarks the next time you open it. But since a few weeks, it is always showing History when clicked, even though I only ever use it for Bookmarks. Is there any way to stop this behaviour?

The sidebar that is brought up by clicking on the sidebar button normally shows whatever you choose on its dropdown menu (Bookmarks, History, or synced tabs). And it used to be, if you choose Bookmarks on that menu, it shows bookmarks the next time you open it. But since a few weeks, it is always showing History when clicked, even though I only ever use it for Bookmarks. Is there any way to stop this behaviour?

All Replies (4)

more options
more options

What happens if you click the sidebar toolbar button and select the bookmarks and then click this button to hide the toolbar and click it another to re-display the sidebar ?

more options

milosagastume11 said

try this: https://support.mozilla.org/en-US/kb/bookmarks-toolbar-display-favorite-websites

Uh, I already have a bookmarks toolbar and that's working fine. I'm talking about the sidebar (shown in my attached image).


cor-el said

What happens if you click the sidebar toolbar button and select the bookmarks and then click this button to hide the toolbar and click it another to re-display the sidebar ?

That used to be the main way to keep it on bookmarks. But it no longer works for good. It does stay on Bookmarks for a while; but after a restart, it reset to History again.

more options

You can try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


You can also try to clear the startup cache via the "Help -> Troubleshooting Information" (about:support) page.