Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't sign in to online banking after Firefox update April 3rd (Ver. 87)

  • 10 uphendule
  • 4 zinale nkinga
  • Igcine ukuphendulwa ngu samandapecora

more options

Windows 10, 64 bit. Firefox ver 87 For the past several days I have not been able to sign into my online banking at Scotiabank. When I enter my user name and password I immediately get an error message "Sorry, we couldn't complete your request". At the top it says "something went wrong" and the message comes from the Scotiabank site saying "generic-error". I've tried refreshing Firefox, removing all cache and cookies. Have tried restarting the computer. I note that Firefox appears to have updated itself on April 3rd and that appears to be when the problem started...could be just coincidental. Other web sites appear fine. I can use Microsoft Edge to log in to Scotiabank just fine as well, but I prefer Firefox. Anyone have thoughts on this? Thanks

All Replies (10)

more options

Sometimes the security certificates are not in sync.

Instead of going to the https website via your bookmark, try to do so from the ground level and initially go to the www version of the site :

open google search search for your bank then click to the bank from the google search then try logging in again.

Okulungisiwe ngu ·´¯`·...¸>-)))º> ~dbben

more options

Thanks for that suggestion, but that didn't work. Same error message.

more options

I went thru google to your bank website. And from there to a login / sign in page at here:

[_https://auth_scotiaonline.scotiabank_com/online?oauth_key=DLudZyTSJuQ&oauth_key_signature=eyJraWQiOiJr (removed by dbben) H_qvQlQ&preferred_environment= ]

When i got to the bank page, this is the url i got. I shortened it due to the huge encrption code. I also replaced the "." with "_" here so this response would not be delayed by mozilla url inspectors:

So can you or can you not get the log in page shown in attached pic?

Do you get a similar url like the one shown above?

When at the scotia site, do you get the same certificates shown in pic 2?

more options

Sorry for the delay getting back to you as I was interrupted and had to take care of some other things. Yes, I get the login page that you sent me the picture of and the site address is the same or similar to the one you get with the auth.scotiabank...etc. Checking the "manage cookies and site data" I get the same three that you get plus another one, which is

Still not able to login...using that login screen that you and I both get.

more options

Win7_64 bit here. Today. Had 2 use Edge 4 NavyFederalCreditUnion login. They said lots of complaints from FF users. FF87.0 was denied all screens. 87.0 blocks downloads of older FF versions. Edge worked again. Youtube full screen mode stopped working w/FF87.0. Worked fine previous to 87.0.

Going back 2 FF86.0.1 downloaded w/Edge. All worked B4 update 2 FF87.0.

I used every screen version & cleared cache & cookies. I get the correct pages but upon sending Name & PW the result is access denied to that login server... Used Edge & previous FF versions w/o problems.

Okulungisiwe ngu John_3_16

more options

Thanks for the additional info John.

I wish I could reproduce the issues you and others are having. However, since i have no account with those sites, then i cant go beyond the login forms.

But my FF is 100% functional for my banks, credit cards and other financial accounts.

It's possible that these sites must grant permission for certain browsers to access their sites. And clearly, MS Edge would be number 1 on everyone's list.

So its possible that when new versions of FF are produced, the sites have not had time to test it.

I have attached a pic of some settings in FF. It would be interesting if the settings could be zero'd out and then see how those login pages react

more options

Could you maybe try logging in just using any user name and password to see if you get a response that your login information is incorrect? Maybe that could give a clue if you don't get that. My user name and password is correct, but I immediately get the "generic error" screen. Of note...there is another problem that just started. When I log in to another site (ePost for Canada Post) I successfully log in, but the screen that comes up for my inbox is garbled, with lots of HTML code mixed in with some of the background. This might be related as it appears to have started about the same time. Again, this ePost site works fine with Microsoft Edge. Thanks again

more options

thanks jim. that was a good idea.

when i tried, i simply got a wrong user name and or password message.

what i did notice is the security certificate is not being downloaded, in my opinion.

for example, go to bank of america, bbva and capital one sites.

then click on the grey padlock icon at the head of the urls

you will find specific info regarding the certificates.

but when you go to scotia bank, it isnt the same as the others.

also, when i reviewed the security certificate details, some of them mentioned the "edge" and another listed "edge, chrome"

i think life is too short for us to continue playing with this issue. as long as people are ok in accessing their financial accounts with the edge, then we can just wait for the mozilla folks to figure this issue out.

take care everyone. and thanks for your time in exploring this issue "in great detail"  !  :-)

more options

Thanks for your help and suggestions. Agreed 100%...we have a workaround until FF folks figure this out so we will do that and not waste any more time. Lots of better stuff to do in life!

more options

I am having problems using FF as well, with both Discover as well as PNC. I searched for help and found this , however the link they send me to doesn't work. I've had to use Chrome 2 months now to pay my bills online.