Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opening Files Automatically

  • 3 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu jscher2000

more options

Hi,

When I attempt to open files instead of saving them I get the dialog box with the check mark for "Do this automatically for files like this from now on." But it asks me this every single time for the same file types.

Do I have any recourse?

Thank you.

Isisombululo esikhethiwe

Usually, this isn't an install issue, it's the way Firefox responds to a signal from the server.

In particular, if a site wants to force a file to be downloaded instead of displaying in a tab, it can set this header:

Content-Disposition: attachment

This causes Firefox to always show a Download dialog. One workaround is to use an add-on which overrides the disposition from attachment to inline. This could break some sites, so it's best to use one that you can turn on/off as needed.

If you want to try mine, here's how:

(A) Install from https://addons.mozilla.org/firefox/addon/content-type-fixer/

(B) Click its Zzzz button to wake it up

(C) Click the button again and in the Content-Disposition Override section, check the box for "Follow my settings (inline)"

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Change your Download Actions under Options > Applications

Locate your file type in the list and see what action it's defaulting to Click the drop-down box beside your file type Change to Use other... and select the application you want to always open with

Now that file type should always open in the desired application without prompting you

Helpful?

more options

strafy said

Change your Download Actions under Options > Applications Locate your file type in the list and see what action it's defaulting to Click the drop-down box beside your file type Change to Use other... and select the application you want to always open with Now that file type should always open in the desired application without prompting you

I tried this and it does not work with some file types. Maybe a fresh reinstall?

Helpful?

more options

Isisombululo Esikhethiwe

Usually, this isn't an install issue, it's the way Firefox responds to a signal from the server.

In particular, if a site wants to force a file to be downloaded instead of displaying in a tab, it can set this header:

Content-Disposition: attachment

This causes Firefox to always show a Download dialog. One workaround is to use an add-on which overrides the disposition from attachment to inline. This could break some sites, so it's best to use one that you can turn on/off as needed.

If you want to try mine, here's how:

(A) Install from https://addons.mozilla.org/firefox/addon/content-type-fixer/

(B) Click its Zzzz button to wake it up

(C) Click the button again and in the Content-Disposition Override section, check the box for "Follow my settings (inline)"

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.