Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After working for years, google maps is saying I don't have access when using firefox. Other browsers work

more options

Looking for suggestions on what I should try to get google maps to work as firefox is my default browser. It still works with other browsers and has worked for years with Firefox.

Looking for suggestions on what I should try to get google maps to work as firefox is my default browser. It still works with other browsers and has worked for years with Firefox.

All Replies (8)

more options

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?


Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

I deleted cookies and cleared the cache but it didn't solve the problem. This is the message:

"We are sorry, but you do not have access to Google Maps. Please contact your Organization Administrator for access."

This is my home computer - no organization administrator like at work. This is new as I have used google maps many times before without issue.

more options

It's not a Firefox message. It comes from somewhere else.

more options

A website like Google Maps probably uses WebGL, so you can check whether WebGL errors reported in the Graphics section on the "Help -> Troubleshooting Information" (about:support) page.

You can also check the Web Console for possible error messages.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options
more options

What organization are you referring to? This is my home computer. There is no organization.

more options

The browser thinks you are part of an organization. Check out the links we posted.

more options

The user in the following painfully long thread was getting the same message. He restarted Firefox in its Safe Mode for testing, found that Google Maps worked, then exited Firefox and restarted it normally and it worked in regular mode, too. No idea whether that will work for you, but possibly worth a try.

https://support.mozilla.org/questions/1331589

In case you didn't find the steps to restart in Firefox's Safe Mode, here's how:

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?