Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cannot get Neflix choices to stream to appear on Firefox after recent update

  • 12 uphendule
  • 1 inale nkinga
  • 29 views
  • Igcine ukuphendulwa ngu babrown

more options

My Netflix screen used to come up with all the choices to stream. Now it only comes up with the titles like "continue watching" or "netflix originals" with nothing underneath them. This just happened, I was using it Tuesday with no problem. It just installed update 87.

I cleaned my cache and history. DRM in enabled. The Open H262 Video Codec plugin is Always Active, The Widevine Content plugin is Always Active.

Not sure where else to look. Netflix works fine on Chrome Browser and Edge Browser.

Windows 10

My Netflix screen used to come up with all the choices to stream. Now it only comes up with the titles like "continue watching" or "netflix originals" with nothing underneath them. This just happened, I was using it Tuesday with no problem. It just installed update 87. I cleaned my cache and history. DRM in enabled. The Open H262 Video Codec plugin is Always Active, The Widevine Content plugin is Always Active. Not sure where else to look. Netflix works fine on Chrome Browser and Edge Browser. Windows 10
Ama-screenshot ananyekiwe

Okulungisiwe ngu babrown

All Replies (12)

more options

That's a cute theme.

Have you seen any errors related to connections?

If I were troubleshooting this on my Firefox, I would take a look at two panels in the Developer Tools: the Web Console (lists errors) and the Network Monitor, which shows the requests Firefox is sending. I know these are an alien world for most users, but it could help, so:

(1) You can open the Web Console in the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Windows) Ctrl+Shift+k

You can click the trash can to clear the existing messages. Then reload the page in the upper part of the tab and watch for error or security messages. Anything that sounds like it indicates a script failure or blocked request?

(2) You can open the Network Monitor by clicking Network on the Developer Tools toolbar.

When you reload the page again, Firefox should start listing all the files it is requesting, along with information about whether the request was successful.

Codes of 400 or higher in the left column, or a persistent blank space, indicates a problem with the server response. Anything like that showing up?

more options

Ok, here's what I got but it means nothing to me. (see picture)

more options

Could you check the "in tab" Developer Tools instead? I'm not sure all of the page errors are logged in the Browser Console. Hopefully Netflix isn't blocking it.

more options

I have no idea what "in tab" means.

more options

Ctrl+Shift+K opens the Web Console in the lower part of the tab. That is the one I had in mind.

Ctrl+Shift+J opens that separate floating Browser Console window. I'm concerned this gives an incomplete view.

more options

Is there any way to get rid of this update? It worked before this.

more options

Were there any errors (red text, probably a different icon) earlier in the list that might explain the problem with that script file that is generating the warnings?

babrown said

Is there any way to get rid of this update? It worked before this.

It's complicated because Firefox will not want to use your profile folder and you'll have to rebuild from scratch.

Speaking of profile files, do you want to try:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like Netflix, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to Netflix and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test.

Note: there might be a short delay while Firefox installed Widevine to play the protected content.

Does the site work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Netflix will remain available for future testing.)

more options

No red text but the first line says:] Some cookies are misusing the recommended “SameSite“ attribute

I tried the new profile and it worked. Now how can I get it to work without destroying my existing profile.

Thanks for all your patience and help.

more options

I tried it again and found this in red: XML Parsing Error: not well-formed Location: https://www.netflix.com/nq/msl_v1/cadmium/pbo_manifests/%5E1.0.0/router?reqAttempt=1&reqPriority=0&reqName=licensedManifest&clienttype=akira&uiversion=vd98b0089&browsername=firefox&browserversion=87.0.0&osname=windows&osversion=10.0 Line Number 1, Column 1:

NEVER MIND - I got this same message on the good Netflix browser that worked. So this has nothing to do with the problem

Okulungisiwe ngu babrown

more options

In your regular profile, if you haven't already, you could try Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

more options

Thanks to both of you for trying to help me. I really appreciate it. None of either of your suggestions worked. No Add-ons installed. Tried Enhanced Tracking both on and off. Did the Forget about site.

I'm just going to use another browser for Netflix. I know this is something unique to my profile on this computer since it works fine on my other computers and laptop.

It's not worth all this trouble. But thanks again.