Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I cannot open the Duolingo website from my Firefox browser on my MAC. It opens fine on my phone.

  • 5 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu FredMcD

more options

I cannot open the Duolingo website from my Firefox browser on my MACbook Air. It opens fine using Firefox on my phone.

All Replies (5)

more options

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?

Please provide a public link (no password) that we can check out. No Personal Information Please !

more options

Thanks for responding. Duolingo is one of my most used sites, so it appears at the top of my Firefox page. I tried clicking it as usual, and I just got 3 dots lighting up sequentially across the page. I waited, but this kept going. I then tried opening the Duolingo site by entering in the URL space, but I got the same result. This time I let it sit for an hour. Still nothing except the three dots. When I open it on my phone either from the app or from typing in the URL, it opened immediately and showed my progress accurately. I always use this app on my Macbook, not on my phone. I can't think of any further relevant info, but will be glad to send more if you have any further questions.

more options

Further to my earlier response, Duolingo sent me an email today suggesting that I study more. It had a link to their site. The lights on the three dots is still moving on my attempt to reach them. Again, it opens right up on my phone. Thank you again for taking an interest.

more options

Is this a new issue? Did it begin with a recent update? Does it happen in safe mode? The correct url is It opens without issue for me. Enhanced Tracking Protection is on and a finger printer has been blocked. Is it possible that your settings on the Privacy page of Preferences are preventing you from accessing the site?

more options

Isisombululo Esikhethiwe