Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove autofill suggestion from Address Bar

more options

Hello,

Sorry if this is a re-post in a way but i needed help. Now, the issue is i am of course a big YouTube user and when i enter 'y', 'yt' or any other combination to get to youtube.com my web address bar always comes up with this website as my first preference for some reason?

https://yoursay.sa.gov.au/

Now, i have tried clearing my cache, website data, search history, cleared everything and even uninstalled and reinstalled Firefox. This site is most certainly not in my bookmarks. How do i permanently remove it form my auto fill data?

I have these stats if it helps:

Firefox version 68.0 64 Bit windows 10 Home Standard Browser Privacy

Any and all help will be greatly appreciated.

Thank you.

Ama-screenshot ananyekiwe

All Replies (5)

more options

To Remove autofill suggestion from Address Bar Firefox, I will suggest to Type yt as you stated and use the arrow keys to highlight the one you want to delete and press <Delete>.

Helpful?

more options

You can try to open the "yoursay.sa.gov.au" website in a tab and use "Forget About This Site" to see if that has effect.

Helpful?

more options

Hello Naheed and Cor-el,

Both of your methods did not work. For Naheed's method it only temporarily removes the site for that current query, but it re-appears every time i try and search again. For yours Cor-el, it clears the data however, the site is still there.

I don't understand considering i have already checked my bookmarks, and cleared all of my cache. There should be no record or cookies from this random website.

Thank you.

Helpful?

more options

What do you mean with "the site is still there" ?

If no longer shows as a suggestion in the location bar drop-down list then where do you see it ?

Helpful?

more options

Hey Cor-el,

So when i type 'yt' and it appears as the first result and it is auto highlighted. If i then hit my Delete key it is removed only for that specific search instance. If i clear the bar, refresh or open a new Firefox window it will reappear after i type 'yt' again.

If i use your method it will clear the cache, but it will still appear as the first predicted website. So neither option works.

Thank you.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.