Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to Stop black Boxes w/Text appearing when mouse hovers over text (any site)?

  • 5 uphendule
  • 1 inale nkinga
  • 232 views
  • Igcine ukuphendulwa ngu Cal

more options

I have no idea how it started or why, but in the past couple days anytime I leave my cursor over a paragraph or chunk of text on a website, a black box appears where my cursor is with the text in it in white. If there is a lot of text, there's a sidebar to scroll down in the box. This disappears as soon as I move my cursor, but reappears as soon as I set it near some more text. I assume this is some kind of accessibility or reading feature, but I have no idea how I turned it or how to get rid of it. I've looked online and in my setting and had no luck getting rid of it. Any help would be appreciated!

I have no idea how it started or why, but in the past couple days anytime I leave my cursor over a paragraph or chunk of text on a website, a black box appears where my cursor is with the text in it in white. If there is a lot of text, there's a sidebar to scroll down in the box. This disappears as soon as I move my cursor, but reappears as soon as I set it near some more text. I assume this is some kind of accessibility or reading feature, but I have no idea how I turned it or how to get rid of it. I've looked online and in my setting and had no luck getting rid of it. Any help would be appreciated!

Isisombululo esikhethiwe

"Translate Web Pages" is a very good extension, but this setting is a little hard to find. In the Translate section of their "More options", turn off "Show translated text when hovering" and see whether that takes care of it:

Credit goes to: https://www.reddit.com/r/firefox/comments/m007q9/whenever_i_leave_my_mouse_hovering_near_any_body/gq55ts3/

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

It isn't! I assume this means it was an add-on doing it? EDIT: It was! Thank you so much! Had to disable a translation add-on.

Okulungisiwe ngu Cal

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

Isisombululo Esikhethiwe

"Translate Web Pages" is a very good extension, but this setting is a little hard to find. In the Translate section of their "More options", turn off "Show translated text when hovering" and see whether that takes care of it:

Credit goes to: https://www.reddit.com/r/firefox/comments/m007q9/whenever_i_leave_my_mouse_hovering_near_any_body/gq55ts3/

Okulungisiwe ngu jscher2000 - Support Volunteer

more options

jscher2000 said

"Translate Web Pages" is a very good extension, but this setting is a little hard to find. In the Translate section of their "More options", turn off "Show translated text when hovering" and see whether that takes care of it: Credit goes to: https://www.reddit.com/r/firefox/comments/m007q9/whenever_i_leave_my_mouse_hovering_near_any_body/gq55ts3/

That did it! Thank you so much!