Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do I have to sign in to sync every single time I open the browswer..? it never remebers me at all until after I sign in.

  • 2 uphendule
  • 1 inale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu jscher2000

more options

It has my sign in saved...but it doesnt let me select it at all as supposed to. Then its like I just downloaded it as a new program every time I open it from my task bar

All Replies (2)

more options

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Helpful?

more options

Peter M said

... its like I just downloaded it as a new program every time I open it from my task bar

This can happen if Firefox launching from a DMG file instead of from the Applications folder. Could you double-check that you have and you are running the permanent installation? This article has the steps: How to download and install Firefox on Mac.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.