Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

On Screen Keyboard will not open, Surface Pro 7

  • 5 uphendule
  • 6 zinale nkinga
  • 73 views
  • Igcine ukuphendulwa ngu Madmitch

more options

I'm using a Surface Pro 7, running Win10H. Firefox had a brief period when I first installed it where the on screen keyboard would appear and work, that stopped after a few hours and has not worked since. I fiddled with the settings on both Firefox and my surface, though nothing has changed. Un/re-installing did not help, thought it could reset something. Any fixes or advice would be greatly appreciated.

For clarification, the Accessibility Menu on-screen keyboard does work, but the tablet-specific larger keyboard does not function. It does open and type in other applications.

All Replies (5)

more options

I haven't looked at this issue for a long time, but back in the day, we would suggest changing the following setting to see whether it makes any difference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste osk and pause while the list is filtered to the on-screen keyboard preferences

(3) Double-click the ui.osk.detect_physical_keyboard preference to switch the value from true to false -- this should prevent Firefox from turning the OSK off when it thinks a keyboard is attached

Does that make any difference?


Last June, numerous Surface users reported problems with the keyboard opening and then immediately closing. Most of those threads weren't solved, but one user said the following resolved it:

(1) Go into

Windows Settings -> Typing -> Touch Keyboard

(2) Turn this setting off and then back on

'Show the Touch Keyboard when not in tablet mode ..."

Seems random, but...

more options

jscher2000 said

I haven't looked at this issue for a long time, but back in the day, we would suggest changing the following setting to see whether it makes any difference: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste osk and pause while the list is filtered to the on-screen keyboard preferences (3) Double-click the ui.osk.detect_physical_keyboard preference to switch the value from true to false -- this should prevent Firefox from turning the OSK off when it thinks a keyboard is attached Does that make any difference?

Last June, numerous Surface users reported problems with the keyboard opening and then immediately closing. Most of those threads weren't solved, but one user said the following resolved it:

(1) Go into

Windows Settings -> Typing -> Touch Keyboard

(2) Turn this setting off and then back on

'Show the Touch Keyboard when not in tablet mode ..."

Seems random, but...

Thank you, the about:config helped for a few minutes! It went back to self closing after a bit, messing with the Windows settings didn't change results. I'm not sure what's causing it to only work for a short period of time though

Okulungisiwe ngu Big Daddy

more options

Sadly, I'm running the May 2020 update (Professional 64bit) on a surface book 2, and none of these helped, Not even for a bit sadly. It works fine with a keyboard, but when in tablet mode, and detached, both criteria have to be met, the touch keyboard still pops up and down, yet never stays, this is a big issue and I hope that maybe there will be some sort of fix or solution. I also want to say I'm running Firefox Release Channel v86.0.1

Okulungisiwe ngu Jumbleton

more options

I have this problem with a Dell Latitude 5290 tablet - but only with Firefox. Using Edge the touchkeyboard stays open, in Firefox it pops open and then closes again before it can be used.

more options

Having the same problem on my surface pro three. The OSK config change and the windows setting toggle doesnt work for me. This is a bit of a game changer Ive come back to Firefox hoping this issue had been fixed but sadley not.