Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Totally Stymied Please Help

  • Akukho zimpendulo
  • 1 inale nkinga
more options

Excuse my long winded explanation but I have a problem with an Acer Nitro Gaming Laptop that I bought 6 months ago when my HP laptop had a hard drive failure. I purchased the new Acer rather than have my HP repaired. After a month of frustration I sent my old HP for repair and have been waiting for a fix for the Acer that appears to have a software issue not a hardware problem. The issue that I'm having is that no matter which browser I'm using it frequently crashes while web browsing. Depending on which browser I'm using I will get the message Oh dear we encountered a problem, or Oh Snap your page crashed or status_access_violation.

The laptop has done this since fresh out of the box no matter what browser that I use and so far I've tried Edge, Chrome, Firefox, and Brave. They all crash which is downright frightening if you are in the midst of doing an online purchase or an online banking transaction. I prefer to use the Firefox browser and have used it for several years.

What I find most interesting is that if I use the old original Internet Explorer that comes in the Windows 10 accessories the laptop is stable and works flawlessly without issues. The main problem is that most web sites no longer support the old explorer and Windows in constantly wanting to update the browser to Edge. Since it works perfectly with the Internet Explorer it leads me to assume that I have a software, coding bug that is unique to the Acer laptop.

In the interim I have a $1,000 doorstop that is of no use to me until a solution is found to this problem. So far I have tried virtually every suggestion out there from updating to the latest versions of the software, trying different browsers and even tried renaming the executable files that initiate the browsers. I have also twice done a full factory reset and started over, none have worked. If anyone out there has a suggestion or solution to this my dilemma please contact me at Thanks!

Okulungisiwe ngu fhpecenka

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.