Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

youtube page not loading properly

  • 6 uphendule
  • 1 inale nkinga
  • 25 views
  • Igcine ukuphendulwa ngu will88taylor

more options

cannot access you tube on firefox browser. Microsoft edge loads up clean. Firefox displays left side buttons, home, trending, etc. Buttons work, nothing else does, no display of videos to peruse. Other screens have videos and everything else works . I can watch videos just not select from latest videos on the home page.

Isisombululo esikhethiwe

Yes my internet is crap. typically it hits 1.5 Mb/sec seldom less than 700kb/s. However as i mentioned it has not been a problem before. Two computers running 3 systems and the only similar problem is firefox. That being said I appreciate your willingness to engage. I've been running two hours this morning and no hiccup in youtube. I hope this problem is gone. Again Thank-you for not blowing me off and helping.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Hmm ... I'm not sure if it's firefox itself, can you send a screenshot of it?

Helpful?

more options

cannot take screen shot. It was loading the youtube page as normal then the left side buttons would come up then the grey boxes would pop up like it was about to populate with videos then the area where the videos would go, is nothing but white screen. Buttons to the left are there, the top line has an enter box, but nothing else.

it worked for a few minutes then back to described problem?

This occurs on my laptop as well as my desk computer

Helpful?

more options

Hi,

Can you tell us more specifically your situation? How long does your problem last? This is often a problem with add-ons.. have you installed a new one recently? Also the screenshot will be very helpful in further investigation.

Thank you

Okulungisiwe ngu Kryštof

Helpful?

more options

Now that you mentioned it I did try to download DCS world, unsuccessfully. However this problem is also on my laptop computer. I do have notoriously slow / bad/ intermitten internet. This has not been an issue before. It just started today. After hitting home several (3-5 )times it does load, so far.

Helpful?

more options

You mentioned some internet problems. According to Google, in order to use YouTube, it is necessary to use an up-to-date browser and also to have a connection speed of at least 500 Kb/s.

You can check your internet speed here.

Helpful?

more options

Isisombululo Esikhethiwe

Yes my internet is crap. typically it hits 1.5 Mb/sec seldom less than 700kb/s. However as i mentioned it has not been a problem before. Two computers running 3 systems and the only similar problem is firefox. That being said I appreciate your willingness to engage. I've been running two hours this morning and no hiccup in youtube. I hope this problem is gone. Again Thank-you for not blowing me off and helping.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.