Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How the firefox search works.

more options

Firefox recently changed the way their searches work. When you click on a website, it only appears on the right half of the screen. Is there any way to change it back the way it was?

Firefox recently changed the way their searches work. When you click on a website, it only appears on the right half of the screen. Is there any way to change it back the way it was?

Isisombululo esikhethiwe

Apparently my searching somehow got changed from from google. Now that I made google my search engine, my searches are like they used to be. My problem is fixed. Thank you very much for all your help.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (12)

more options

Hi, is this different than the problem we discussed the other day in the following thread:

https://support.mozilla.org/questions/1326013

more options

Yes, this is the same problem we discussed the other day but I still don't understand how to eliminate the website from appearing on the right half of the screen.

more options

I need to have things explained to me as though I were an 8 year old. I'm not very computer smart.

more options

Okay, if you are using Google for your searches, the first thing to check is the current Google settings. To get to those, go to the Google Search Settings page at

https://www.google.com/preferences

Scroll down to the "Where results open" section and make sure there is not a checkmark in this box:

[_] Open each selected result in a new browser window

If there is a checkmark:

Uncheck it and use the Save button at the bottom of that page. The next time you run a search, the results should open in the same tab instead of a new window.

more options

There was no checkmark in the "where results open" box. You said "Open each selected result in a new browser window" but I saw no selected results.

more options

Never mind the statement "You said open each selected result in a new browser window" but I saw no selected results." I meant to say there was no checkmark in that box.

more options

Okay, thank you for checking that.

But you still have the same problem that instead of your Google search results links opening in the same tab, they open in a separate new window on the right side of the screen.

Maybe I'm wrong in assuming that you do your searches on Google. Is it Google or are you using a different search site now?

more options

I think my searches are done on firefox. The firefox symbol is on my tabs.

more options

I'm not sure but I think my searches used to be done with google. I looked on the computer I had about a month ago and the google search bar was on my new tabs. Maybe when the technician set up my new computer, it was set up with firefox instead.

more options

When you first install Firefox, it sends your searches to the Google website. However, you can change that, or add-ons can change that. It's your choice. You should be able to tell which one your are using from the logo on the page or the address in the address bar. I have attached a composite screenshot of some examples.

more options

Isisombululo Esikhethiwe

Apparently my searching somehow got changed from from google. Now that I made google my search engine, my searches are like they used to be. My problem is fixed. Thank you very much for all your help.

more options

Great! I'll mention one more things for future reference:

Sometimes, changes to your preferred search site are made by extensions. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

In some cases, a bad extension will block or blank the extensions panel of the Add-ons page somehow. To complete the above, you can restart Firefox in its Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Then you should be able to finish the clean-up and retain control.